Bug 271221 - Sound doesn't work (HP Pavilion dv2140/MCP51/Conexant CX20549)
Sound doesn't work (HP Pavilion dv2140/MCP51/Conexant CX20549)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
7
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-31 09:04 EDT by LH
Modified: 2008-01-01 11:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-01 11:03:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (2.33 KB, text/plain)
2007-08-31 09:04 EDT, LH
no flags Details
scsconfig.log (48.51 KB, text/plain)
2007-09-10 07:38 EDT, LH
no flags Details
scsrun.log (220 bytes, text/plain)
2007-09-10 07:39 EDT, LH
no flags Details

  None (edit)
Description LH 2007-08-31 09:04:16 EDT
Description of problem:

Sound doesn't work at all even if I set every mixer setting there is to the max
and make sure nothing is muted. Some old version of Arch Linux used to show
sliders for internal speakers and headphones and this needed to be activated but
Fedora doesn't show anything like this.

Version-Release number of selected component (if applicable):

Latest from fedora-updates
Comment 1 LH 2007-08-31 09:04:16 EDT
Created attachment 183261 [details]
lspci
Comment 2 Martin Stransky 2007-09-10 06:14:09 EDT
Please run system-config-soundcard, create sound logs (/root/scsconfig.log and
/root/scsrun.log) and attach it here.
Comment 3 LH 2007-09-10 07:38:42 EDT
Created attachment 191561 [details]
scsconfig.log
Comment 4 LH 2007-09-10 07:39:14 EDT
Created attachment 191571 [details]
scsrun.log
Comment 5 LH 2007-10-10 12:57:18 EDT
This also happens with

Linux fed-lap 2.6.23-0.224.rc9.git6.fc8 #1 SMP Mon Oct 8 14:47:56 EDT 2007
x86_64 x86_64 x86_64 GNU/Linux
Comment 6 Klaus Möllenhoff 2007-11-20 09:10:28 EST
is it the same as my bug was?

https://bugzilla.redhat.com/show_bug.cgi?id=372641

i see you have a conexant modem? do you have drivers installed for it?
Comment 7 LH 2007-11-22 09:58:59 EST
I don't have any drivers for the modem unless system automatically installs some.

With the fedora 8 release the line-out now works but internal speakers don't. So
I'd say this is an issue with mixer channels as I've had sound coming out from
speakers with some old Arch Linux version in last spring. Though I can't check
what differences there were to current fedora because of Arch's rolling release
system.
Comment 8 Jan Sonnek 2007-11-25 09:49:54 EST
You have your own kernel of FC8 kernel? If you have your kernel you have to add
acl tmps to kernel:

CONFIG_TMPFS=y
CONFIG_TMPFS_POSIX_ACL=y
Comment 9 LH 2007-11-25 11:18:27 EST
No. I've upgraded to Fedora 8 with stock kernel and the bug still applies. So
this applies to both 7 and 8.
Comment 10 LH 2008-01-01 11:03:12 EST
Now sound works perfectly with Fedora 8. It even automatically switches to
headphones when I plug them in.

Note You need to log in before you can comment on or make changes to this bug.