Bug 27133 - Old version of python included
Old version of python included
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: python (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
: 31677 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-12 05:49 EST by Magnus Heino
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 05:49:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Magnus Heino 2001-02-12 05:49:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


Redhat ships new versions of almost all programs included in fisher. Even 
beta versions of some programs are included. 

The python version included is v1.5.2. This version was released 13 April 
1999. Since then, 1.6, 2.0 has been released, and 2.1 is in alpha two 
stage now.

I guess the reason for this is because lots of your admintools are using 
1.5.2, and it takes some time to test (and maybe change some) them with 
2.0.

Ths solution is simple, ship both. It's not a problem at 
all. /usr/bin/python is a link, today pointing at /usr/bin/python1.5

Include python2.0 and 1.5, have the /usr/bin/python point 
at /usr/bin/python2.0 and update your scripts to use /usr/bin/python1.5 
and it will all work.

This is what I have been doing manually for a while...

The Python language is growing fast. Please dont let people use an old 
version.

Reproducible: Always
Steps to Reproduce:
-
	

Actual Results:  -

Expected Results:  -

-
Comment 1 Matt Wilson 2001-02-12 11:31:13 EST
Python 2.0 is on the Powertools CD of fisher.  It will become the default in the
next major (.0) release of Red Hat Linux.
Comment 2 Matt Wilson 2001-03-13 12:03:38 EST
*** Bug 31677 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.