Bug 31677 - Please upgrade to python2.0
Summary: Please upgrade to python2.0
Status: CLOSED DUPLICATE of bug 27133
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: python (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-13 16:10 UTC by Neal D. Becker
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-13 16:10:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Neal D. Becker 2001-03-13 16:10:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2 i686; Nav)


Since python is used by system utils, but scripts don't specify the
version, it is very difficult for a user to upgrade to python2.0 without
breaking system utils.  If you simply install python2.0 distr system utils
break, because RH adds LOTS of python packages that are not part of the
standard python2.0 distr.

3 solutions:
1) Make python2.0 standard
2) Put #!python1.5 at the start of all system scripts
3) Make it easy to get all the RH added python packages that would be
needed to upgrade python

IMHO, you should do both 1, 2, and 3.

Reproducible: Didn't try

Comment 1 Matt Wilson 2001-03-13 17:03:42 UTC
Python 2.x will be included in the next Major release (.0) of Red Hat Linux. 
Until then our binary compatibility rules prevent us from deploying it.  The
next release of Red Hat Linux (7.1) will have a python2 package on the
Powertools CD and /usr/bin/python2.  This is part of our Python 2.x migration
plan.


*** This bug has been marked as a duplicate of 27133 ***


Note You need to log in before you can comment on or make changes to this bug.