Bug 27158 - up2date fails dependency check when -a option used
Summary: up2date fails dependency check when -a option used
Status: CLOSED DUPLICATE of bug 28369
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-12 17:27 UTC by mnelson
Modified: 2015-01-07 23:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 03:24:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mnelson 2001-02-12 17:27:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.18-mosix i686; en-US; 0.7)
Gecko/20010111


up2date gives error message 'There was a fatal RPM error.  The message was:
Don't know how to handle dependency sense "1"' when option -a is used.

Reproducible: Always
Steps to Reproduce:
1. Run the command "up2date --nosig -ua"	

Actual Results:  [root@man /root]# up2date --nosig -ua

Retrieving list of all available packages...

Removing installed packages from list of updates...
100.0%
Removing packages marked to skip from list...
100.0%
Getting headers for available packages...
100.0%
Removing packages with files marked to skip from list...
100.0%
Getting headers for skipped packages...
100.0%
Testing package set / solving RPM inter-dependencies...
There was a fatal RPM error.  The message was:
Don't know how to handle dependency sense "1"


If the -a option is omitted, the command completes as expected.  All
software on the system has been updated (i.e., its current).  The command:
"up2date --nosig -la" returns a very long list of packages that are
evidently not currently installed on my system.  If the exact list is
important, please contact me and I will provide it.

Comment 1 Cristian Gafton 2001-02-20 01:35:05 UTC
Assigned QA to jturner

Comment 2 Need Real Name 2001-02-26 03:24:31 UTC
I was trying to use up2date with the "Display all packages available, not only
those
installed on the system" flag turned on by up2date-config.  up2date (GUI) just
sat there for ever until I killed it.

I then tried to do a 

  up2date --nosig --list -a

and go the following:

# up2date --nosig --list -a

Retrieving list of all available packages...

Removing installed packages from list of updates...
100.0%
Removing packages marked to skip from list...
100.0%
Getting headers for available packages...
100.0%
Removing packages with files marked to skip from list...
There was a fatal RPM error.  The message was:
error reading from database
#

This is under RedHat 7.0 / i386 (up2date 2.1.7)

Comment 3 Preston Brown 2001-02-26 23:57:25 UTC
failed because of a conflict.

*** This bug has been marked as a duplicate of 28369 ***


Note You need to log in before you can comment on or make changes to this bug.