Bug 27174 - error mounting hdb1: Invalid argument
error mounting hdb1: Invalid argument
Status: CLOSED DUPLICATE of bug 16686
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-12 12:57 EST by Need Real Name
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 14:29:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-12 12:57:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)


He installs great unti the program reaches the point after he formatted my 
partitions; then I get this message "error mounting hdb1: invalid argument"

Reproducible: Always
Steps to Reproduce:
1. I partition my hdb drive as follows:
* /
* swap
* /BOOT
	

Actual Results:  He crashed, and I had to restart my system.

Expected Results:  That he installed properly !

The error message

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713, in 
mountFilesystems
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 1024096
fsystem: ext2
self: <fstab.NewtFstab instance at 833fcd8>
msg: Invalid argument
doFormat: 1
errno: 22
device: hdb1
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I0
sS'fnames'
p9
(dp10

<failed>
Comment 1 Michael Fulbright 2001-02-12 13:30:13 EST
Did you got back/forwards during the install?
Comment 2 Need Real Name 2001-02-12 14:04:49 EST
No, I didn't get any back or forwards....

I also applied the Update Disk that you can find by Updates/Images on the FTP 
site, but that didn't help either....

Comment 3 Michael Fulbright 2001-02-13 23:25:31 EST
Did you autopartition, use Disk Druid, or fdisk (from the installer menu)?
Comment 4 Need Real Name 2001-02-14 11:47:55 EST
I used Disk Druid
Comment 5 Michael Fulbright 2001-02-21 18:15:25 EST
If you reboot and use the partitions you created in the previous attempt,
without destroying and recreating them, does it work?
Comment 6 Need Real Name 2001-03-02 09:58:59 EST
No, that doesn't work either....

Would it help if I would partition it with another program, like Part Magic 
6.0, or fdisk ?

thanx
Comment 7 Michael Fulbright 2001-03-05 17:39:57 EST
You could try repartitioning with fdisk.
Comment 8 Josh Gant 2001-03-06 11:15:47 EST
I am having the same prob.  I have ran fdisk several times (swap, /boot, /, 
each of these as different partition numbers), and I see the same result.  I a 
have an Adaptec AIC-7XXX SCSI Controller.

Here is the crash:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, 
in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "fstab.py", line 715, in mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 8570677
fsystem: ext2
self: <fstab.GuiFstab instance at 8448910>
msg: Invalid argument
doFormat: 0
errno: 22
device: sda2
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

If you would like me to start a new bug/ticket, let me know.

Thanks a lot,

- Josh


Comment 9 Ron Dennis II 2001-03-07 23:31:47 EST
I am having the same problem too... all the way down to the Adeptec AIC 7XXX SCSI Controller.
The crash is the IDENTICAL except for the drive, mine errors on sdc1.
The partitions are: / on sda1 = 4 gig,  swap on sdb5 = 300mb, /var on sdb6 = 2 gig, /cache on sdb1 = 1.7 gig, and /home on sdc1 = 4 gig
Let me know if you need more info.
--Ron
Comment 10 Ron Dennis II 2001-03-08 00:46:07 EST
SOLUTION!!!
Problem solved!! 
Download the existing anaconda update.
I did check disks for bad sectors... it had completed format twice before...
I hope this helps you all!!
--Ron
Comment 11 jay green 2001-03-26 00:15:00 EST
sumary:  i got an error message similar to the adaptec report.  a few lines 
different.  i have a 13 g western digital hard drive.  this is my first 
experience with linux so i dont know much else other than my system wont 
install.  

history:  i installed linux red hat 7 two days ago.  it deleted my windows 
partition and all my data but it left me with linux running fine so i didnt 
really care too much about losin winblows.  then i shut down to go away and 
came back this evening and booted up and recieved nothing but an L on a black 
screen.  i formatted the partition with fdisk and it was still booting to the L 
screen.  so i deleted the partition and created a new one.  removing the dos 
disk i was expecting it to return an 'operating system not found' message but 
instead still got the L.  so i assumed L meant Lilo so i booted using the linux 
boot disk.  it did its Lilo thing and then i booted with the cdrom.  its now a 
good five hours later and i have reformated and reinstalled several times and 
each time i recieve this error message.  so now i have come here seeking the 
smart ones.  
thanks...

error message:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in 
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in 
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/rootpartition_gui.py", 
line 133, in getScreen
    avail = apply(isys.spaceAvailable, self.todo.fstab.getRootDevice())
  File "/usr/lib/anaconda/isys.py", line 10, in spaceAvailable
    mount(device, "/mnt/space", fstype = fsystem)
  File "/usr/lib/anaconda/isys.py", line 99, in mount
    rc = _isys.mount(fstype, device, location, readOnly)
SystemError: (22, 'Invalid argument')
Local variables in innermost frame:
fstype: vfat
location: /mnt/space
devName: /tmp/hda1
readOnly: 0
device: /tmp/hda1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6
<failed>
Comment 12 jay green 2001-03-26 00:16:44 EST
sumary:  i got an error message similar to the adaptec report.  a few lines 
different.  i have a 13 g western digital hard drive.  this is my first 
experience with linux so i dont know much else other than my system wont 
install.  

history:  i installed linux red hat 7 two days ago.  it deleted my windows 
partition and all my data but it left me with linux running fine so i didnt 
really care too much about losin winblows.  then i shut down to go away and 
came back this evening and booted up and recieved nothing but an L on a black 
screen.  i formatted the partition with fdisk and it was still booting to the L 
screen.  so i deleted the partition and created a new one.  removing the dos 
disk i was expecting it to return an 'operating system not found' message but 
instead still got the L.  so i assumed L meant Lilo so i booted using the linux 
boot disk.  it did its Lilo thing and then i booted with the cdrom.  its now a 
good five hours later and i have reformated and reinstalled several times and 
each time i recieve this error message.  so now i have come here seeking the 
smart ones.  
thanks...

error message:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in 
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in 
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/rootpartition_gui.py", 
line 133, in getScreen
    avail = apply(isys.spaceAvailable, self.todo.fstab.getRootDevice())
  File "/usr/lib/anaconda/isys.py", line 10, in spaceAvailable
    mount(device, "/mnt/space", fstype = fsystem)
  File "/usr/lib/anaconda/isys.py", line 99, in mount
    rc = _isys.mount(fstype, device, location, readOnly)
SystemError: (22, 'Invalid argument')
Local variables in innermost frame:
fstype: vfat
location: /mnt/space
devName: /tmp/hda1
readOnly: 0
device: /tmp/hda1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6
<failed>
Comment 13 Brent Fox 2001-04-11 14:29:32 EDT
These bugs are duplicates of #16686...a bug with a long history.  It's long
since been fixed in our internal testing builds.

*** This bug has been marked as a duplicate of 16686 ***

Note You need to log in before you can comment on or make changes to this bug.