Bug 2719 - Raid partitions created in RH5.2 don't work with RH6.0
Raid partitions created in RH5.2 don't work with RH6.0
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
6.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Erik Troan
:
: 3026 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-10 16:09 EDT by Carl Roth
Modified: 2008-05-01 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 10:44:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Roth 1999-05-10 16:09:41 EDT
The new raid system provided with RH6.0 will not read
raid partitions created by RH5.2.  This should be clearly
stated in the install guide!  Ouch!

This causes two problems:

1.  Raid systems seen during upgrade cause the upgrade
    to fail.

2.  Raid systems existing after upgrade are not readable
    by RH6.

The only workaround I know of (other than doing a backup
before the upgrade ;-) ) is as follows:

1.  unpack modules-XXX and raidtools-XXX from RH5.2 dist.
2.  boot 2.0.XXX from RH5.2 install floppy
3.  hand-mount raid systems and copy data away
4.  re-boot into 2.2.XXX and recreate raid partitions.
Comment 1 Anonymous 1999-05-25 08:19:59 EDT
Copying the ckraid and raidrun from an old 5.2 system is enough to
fix this problem. Don't forget to link raidadd, raidstart(delete the
new binary) and raidstop to the old raidrun binary.
But anyway, it's a nice surprise for someone with just one machine
or without an old raidpackage.
Comment 2 Brian Feeny 1999-07-02 09:39:59 EDT
This is just not right.  Basically anyone who had RAID's built in 5.2,
a function fully supported and endorsed by Redhat, is dead in the
water in 6.0 after upgrading.

Their exists a "mkraid --upgrade" flag.  Can someone at redhat please
describe how this is to be used to "upgrade" older style raids to the
newer style?

Using persistant superblocks on older style raids will destroy the
data.  I set "persistant-superblock = 0" in my /etc/raidtab file.  I
then try to "/sbin/mkraid --upgrade /dev/md0" to try and upgrade to
the newer style raid:

[root@sol raidtools-0.90]# /sbin/mkraid --upgrade /dev/md0
handling MD device /dev/md0
analyzing super-block
disk 0: /dev/hdc1, 11255296kB, raid superblock at 11255232kB
cannot upgrade magic-less superblock on /dev/hdc1 ...
mkraid: aborted

1. Their should be a big warning that all RAIDS will break in
upgrading from 5.2 to 6.0.

2. Their should be a solution posted somewhere (here, knowledgbase,
etc) about how to fix this.

3. Their are threads related to this on redhat-list, which no one from
redhat has come forward to answer to.
Comment 3 Bill Nottingham 1999-08-19 17:50:59 EDT
*** Bug 3026 has been marked as a duplicate of this bug. ***

After upgrading from 5.2 to 6.0 , raidstart fails
with the error:

/dev/md0: Invalid argument

raidtab is included below.
/var/log/messages:
May 24 17:28:48 cholla kernel: raid0 personality registered
May 24 17:29:04 cholla kernel: (read) sdb1's sb offset:
4192832 [events: 6c6c6c6
c]
May 24 17:29:04 cholla kernel: md: invalid raid superblock
magic on sdb1
May 24 17:29:04 cholla kernel: md: sdb1 has invalid sb, not
importing!
May 24 17:29:04 cholla kernel: could not import sdb1!
May 24 17:29:04 cholla kernel: autostart sdb1 failed!
May 24 17:29:04 cholla kernel: huh12?


raiddev                 /dev/md0
raid-level              0
persistent-superblock   0
nr-raid-disks           2
nr-spare-disks          0

device                  /dev/sdb1
raid-disk               0

device                  /dev/sdc1
raid-disk               1


------- Additional Comments From andreas.Busch@munich.netsurf.de  05/25/99 08:24 -------
I had the same problem with Raid1 partitions, see Bug ID 2719 for
workaround.
Comment 4 Erik Troan 2000-02-03 10:44:59 EST
There is no good resolution to this; while there are ways of forcing this
to work, we strongly recommend all of our customers upgrade to the new
raid system.

Note You need to log in before you can comment on or make changes to this bug.