Bug 3026 - raid 0 fails on old raid partitions.
raid 0 fails on old raid partitions.
Status: CLOSED DUPLICATE of bug 2719
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-25 00:17 EDT by Dmitri A. Sergatskov
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-19 17:50:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri A. Sergatskov 1999-05-25 00:17:44 EDT
After upgrading from 5.2 to 6.0 , raidstart fails
with the error:

/dev/md0: Invalid argument

raidtab is included below.
/var/log/messages:
May 24 17:28:48 cholla kernel: raid0 personality registered
May 24 17:29:04 cholla kernel: (read) sdb1's sb offset:
4192832 [events: 6c6c6c6
c]
May 24 17:29:04 cholla kernel: md: invalid raid superblock
magic on sdb1
May 24 17:29:04 cholla kernel: md: sdb1 has invalid sb, not
importing!
May 24 17:29:04 cholla kernel: could not import sdb1!
May 24 17:29:04 cholla kernel: autostart sdb1 failed!
May 24 17:29:04 cholla kernel: huh12?


raiddev                 /dev/md0
raid-level              0
persistent-superblock   0
nr-raid-disks           2
nr-spare-disks          0

device                  /dev/sdb1
raid-disk               0

device                  /dev/sdc1
raid-disk               1
Comment 1 Anonymous 1999-05-25 08:24:59 EDT
I had the same problem with Raid1 partitions, see Bug ID 2719 for
workaround.
Comment 2 Bill Nottingham 1999-08-19 17:50:59 EDT
*** This bug has been marked as a duplicate of 2719 ***

Note You need to log in before you can comment on or make changes to this bug.