Bug 27199 - file can't stat large files (> 2GB)
file can't stat large files (> 2GB)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: file (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
Aaron Brown
:
: 42110 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-12 14:53 EST by Need Real Name
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 14:53:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-12 14:53:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Windows NT 5.0; U)


When trying to identify a large file using `file`, it reports that it can't stat it.  Of course, you have to be running a 2.4.X kernel to do this since 2.2 
kernels don't support large files.

shooter:~> ls -l /tmp/bigfile 
-rw-rw-r--    1 drees    drees     3145728000 Feb 10 11:29 /tmp/bigfile
shooter:~> file /tmp/bigfile
/tmp/bigfile: can't stat `/tmp/bigfile' (Value too large for defined data type).
shooter:~> 

Reproducible: Always
Steps to Reproduce:
1. Create large file using dd:  `dd if=/dev/zero of=/tmp/bigfile bs=1M count=3000
2. Attempt to determine the file type `file /tmp/bigfile`
Comment 1 Nalin Dahyabhai 2001-02-14 23:25:51 EST
This appears to work correctly in Raw Hide.
Comment 2 Jeremy Sanders 2001-06-12 04:45:09 EDT
*** Bug 42110 has been marked as a duplicate of this bug. ***
Comment 3 Nick Lamb 2001-08-01 00:25:09 EDT
RawHide doesn't seem to fix it for me, running file-3.35-2.i386.rpm from RawHide...
rpm -q file
file-3.35-2

ls -lH HUGE
-rw-rw-r--    1 ruth     ruth         5.2G Aug  1 05:02 HUGE

file HUGE
HUGE: can't stat `HUGE' (Value too large for defined data type).

Note You need to log in before you can comment on or make changes to this bug.