Bug 273561 - music play programs can't play mp3.
music play programs can't play mp3.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-good (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Reopened
Depends On: 274571
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-01 02:50 EDT by sangu
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.10.6-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 15:01:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 471370 None None None Never

  None (edit)
Description sangu 2007-09-01 02:50:20 EDT
Description of problem:
banshee or rhythmbox can't play mp3.


Version-Release number of selected component (if applicable):
0.10.14-4.fc8

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Installed gstreamer-plugins-ugly-0.10.6-1.lvn8
No problem in gstreamer-plugins-base-0.10.14-4.fc8
Comment 1 Ignacio Vazquez-Abrams 2007-09-01 02:58:23 EDT
Fedora does not supply gstreamer-plugins-ugly; closing pending proof that this
is caused by a Fedora package.
Comment 2 sangu 2007-09-01 05:17:32 EDT
This isn't gstreamer-plugins-ugly bug. 

After updating gstreamer-plugins-base-0.10.4-5.fc8, music player works wrong.
Comment 3 Hans de Goede 2007-09-02 10:00:32 EDT
This problem is caused by the addition of the
gstreamer-plugins-base-0.10.14-unsupported-codec.patch
to the latest gstreamer-plugins-base package, see:
https://bugs.launchpad.net/ubuntu/+source/gst-plugins-ugly0.10/+bug/136264
http://bugzilla.gnome.org/show_bug.cgi?id=471370

The upstream (gnome) bugreports suggests applying the following patch (already
in upstream CVS) against gstreamer-plugins-good:
http://webcvs.freedesktop.org/gstreamer/gst-plugins-good/gst/id3demux/gstid3demux.c?r1=1.29&r2=1.30

I've tried it and this indeed fixes this, changing the component to match.
Comment 4 Bastien Nocera 2007-09-02 11:16:51 EDT
Waiting on the policykit bug to be fixed to finish the build:
http://koji.fedoraproject.org/koji/getfile?taskID=145042&name=root.log
Comment 5 Bastien Nocera 2007-09-04 15:01:57 EDT
Fixed in rawhide.
Comment 6 sangu 2007-09-09 06:45:33 EDT
In gstreamer-plugins-base-0.10.14-5.fc8 , gstreamer-plugins-good-0.10.6-5.fc8

Loading several mp3 file  in rhythmbox, rhythmobx can't play the mp3 (internal
data flow error).

But rhythmbox works well in gstreamer-plugins-base-0.10.14-4.fc8.i386.

http://hellocity.net/~sangu/etc/rhythmbox/01%20-%20Aces%20High.mp3
http://hellocity.net/~sangu/etc/rhythmbox/screenshot2.png
Comment 7 Bastien Nocera 2007-09-09 11:13:17 EDT
You also need an updated gstreamer-plugins-good. Version 0.10.6-5 has the fix.
See bug 273561. You might also need a gstreamer-plugins-bad with the fix, as per
upstream's advice.

Note You need to log in before you can comment on or make changes to this bug.