Bug 274571 - Can't build packages depending on hal-devel
Summary: Can't build packages depending on hal-devel
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All All
medium
low
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 273561
TreeView+ depends on / blocked
 
Reported: 2007-09-02 15:15 UTC by Bastien Nocera
Modified: 2013-03-06 03:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 18:36:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bastien Nocera 2007-09-02 15:15:43 UTC
On today's koji builds:
http://koji.fedoraproject.org/koji/taskinfo?taskID=145038

From the log:
http://koji.fedoraproject.org/koji/getfile?taskID=145042&name=root.log
Executing /usr/sbin/mock-helper yum --installroot
/var/lib/mock/dist-f8-build-47595-5689/root install  'libX11-devel'
'libiec61883-devel' 'esound-devel >= 0.2.8' 'gtk2-devel' 'libraw1394-devel'
'libavc1394-devel' 'libcdio-devel' 'glibc-devel' 'ladspa-devel' 'hal-devel'
'mikmod' 'gettext' 'libpng-devel >= 1.2.0' 'cairo-devel' 'gcc-c++'
'libshout-devel' 'PyXML' 'speex-devel' 'liboil-devel >= 0.3.6' 'gstreamer-devel
>= 0.10.6' 'gtk-doc' 'libjpeg-devel' 'GConf2-devel'
'gstreamer-plugins-base-devel >= 0.10.6' 'flac-devel >= 1.1.3' 'wavpack-devel'
'taglib-devel' 'libdv-devel'
Error: Missing Dependency: libpolkit.so.1 is needed by package PolicyKit-gnome
Error: Missing Dependency: libpolkit-grant.so.1 is needed by package PolicyKit-gnome
Error: Missing Dependency: libpolkit-dbus.so.1 is needed by package PolicyKit-gnome

Comment 1 David Zeuthen 2007-09-02 18:21:26 UTC
Pretty sure this is a build-system problem; it's bogus that PolicyKit-gnome is
pulled in by hal-devel.

FWIW, I encountered the same problem when I tried to rebuild PolicyKit-gnome.

Reassigning to buildsystem (unsure if it's the right component).

Comment 2 Bastien Nocera 2007-09-02 18:45:54 UTC
I _think_ it's hal-devel pulling it, but not having the full deps logs from yum
I wouldn't know for sure.

Comment 3 Seth Vidal 2007-09-02 19:47:31 UTC
PolicyKit-gnome is being pulled in by gnome-mount which is being pulled in by
gnome-vfs2 which is being pulled in by gstreamer-plugins-base which is being
pulled in by gstreamer-plugins-base-devel which is a build dep of hal-devel

'gstreamer-plugins-base-devel >= 0.10.6'

Pretty sure this is not a buildsys bug.


Comment 4 Bastien Nocera 2007-09-02 20:19:10 UTC
Ha! Thanks Seth.
David, does gnome-mount need a rebuild or something?

Comment 5 Matthias Clasen 2007-09-04 18:28:32 UTC
I have fixed the PolicyKit-gnome rebuild problem by now.


Note You need to log in before you can comment on or make changes to this bug.