Bug 27390 - CD installation fails silently, crashes or hangs if CD is corrupt
CD installation fails silently, crashes or hangs if CD is corrupt
Status: CLOSED DUPLICATE of bug 17928
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 09:41 EST by Alex Schuilenburg
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 12:41:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Schuilenburg 2001-02-13 09:41:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)


The boxed RH7.0 Professional we received at the Cambridge offices contained
a bad CD (Binary #1), unkown to us at the time. 

The GUI installation did not report any errors when attempting to install
these RPMs and silently failed leaving you with the impression that the
install worked, or leaving you in no doubt that there was a problem during
istallation (but no idea to the cause). 

Reproducible: Always
Steps to Reproduce:
1. Start a custom istallation (Do not select GUI login (level 5)) and
ensure one of the corrupt (unreadable) RPMs is included (util-linux always
should be by default).  Either your install will hang, crash (see log), or
fail silently.  For the latter continue with 2&3
2. Reboot as per normal
3. Attempt to login as root (fails as login was not installed)
	

Actual Results:  For the hang, the install, er, hung.
For the crash, see additional info for the anaconda.txt
For the silent failure, you could not login in level 3.

Attempting to read each RPM in full off the CD revealed 3 bad RPMs, one of
which was util-linux.  It was only after the silent fail that I could
reboot and bring up the system in single-user to discover that util-linux
(and hence login) did not install.


Expected Results:  Error reporting failure reading the RPM off the CD.

anaconda.txt
==========
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1632, in
doInstall
    self.writeConfiguration ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1384, in
writeConfiguration
    self.createAccounts ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1168, in
createAccounts
    stdout = devnull)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 40, in
execWithRedirect
    raise RuntimeError, command + " can not be run"
RuntimeError: /usr/bin/chfn can not be run

Local variables in innermost frame:
argv: ['/usr/bin/chfn', '-f', 'Alex Schuilenburg', 'alex']
root: /mnt/sysimage
stdin: 0
newPgrp: 0
stdout: 25
stderr: 2
command: /usr/bin/chfn
searchPath: 0
ignoreTermSigs: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I2
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdd'
sS'progressWindow'
p9

<failed>
Comment 1 Michael Fulbright 2001-02-13 23:07:16 EST
We have a feature request for rpmlib in that would let us know when a package
failed to install properly. At the moment we are not notified of this failure.
To the installer it looks like the package install was completely and its time
to move on.

This is understandably irritating to you and I apologize for the inconvenience
it caused.
Comment 2 Michael Fulbright 2001-09-18 12:41:23 EDT

*** This bug has been marked as a duplicate of 17928 ***

Note You need to log in before you can comment on or make changes to this bug.