Bug 27424 - anaconda crashes trying to install through nfs
anaconda crashes trying to install through nfs
Status: CLOSED DUPLICATE of bug 18648
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 13:12 EST by David Grote
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-13 13:12:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Grote 2001-02-13 13:12:14 EST
Trying to install redhat 7.0 through nfs using kickstart.  Once anaconda 
starts up it outputs this error message.  If this has been corrected or it 
is classic operator error, please let me know.

Thanx
David Grote


Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-
7.0.1//usr/lib/anaconda/textw/partitioning_text.py", line 134, in __call__
    todo.lilo.allowLiloLocationConfig(todo.fstab)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/lilo.py", line 124, in 
allowLiloLocationConfig
    if bootDevice[0:2] == "md":
TypeError: unsliceable object

Local variables in innermost frame:
fstab: <fstab.NewtFstab instance at 820b900>
self: <lilo.LiloConfiguration instance at 8289bf0>
bootDevice: None

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
NfsInstallMethod
p4
(dp5
S'tree'
p6
S'/mnt/source/.'
sbsS'initlevel'
p7
I3
sS'progressWindow'
p8
NsS'expert'
p9
I0
sS'ddruidReadOnly'
p10
I0
sS'bootdisk'
p11
I0
sS'language'
p12
(itodo
Language
(dp13
S'abbrevMap'
p14
(dp15
S'es_ES'
p16
S'Spanish'
p17
sS'tr_TR'
p18
S'Turkish'
p19
sS'sr_YU'
p20
S'Serbian'
p21
sS'de_DE'
p22
S'German'
p23
sS'sk_SK'
p24
S'Slovak'
p25
sS'ru_RU.KOI8-R'
p26
S'Russian'
p27
sS'is_IS'
p28
S'Icelandic'
p29
sS'no_NO'
p30
S'Norwegian'
p31
sS'sv_SE'
p32
S'Swedish'
p33
sS'en_US'
p34
S'English'
p35
sS'it_IT'
p36
S'Italian'
p37
sS'da_DK'
p38
S'Danish'
p39
sS'cs_CZ'
p40
S'Czech'
p41
sS'uk_UA.KOI8-U'
p42
S'Ukrainian'
p43
sS'hu_HU'
p44
S'Hungarian'
p45
sS'fr_FR'
p46
S'French'
p47
sS'sl_SI'
p48
S'Slovenian'
p49
sS'ro_RO'
p50
S'Romanian'
p51
ssS'font'
p52
(dp53
g37
S'lat0-sun16'
sg21
S'cyr-sun16'
sg27
S'cyr-sun16'
sg35
S'None'
sg25
S'lat2-sun16'
sg31
S'lat0-sun16'
sg33
S'lat0-sun16'
sg47
S'None'
sg49
S'lat2-sun16'
sg51
S'lat2-sun16'
sg23
S'None'
sg19
S'lat5-sun16'
sg45
S'lat2-sun16'
sg17
S'None'
sg43
S'cyr-sun16'
sg41
S'lat2-sun16'
sg39
S'lat0-sun16'
sg29
S'lat0-sun16'
ssS'langs'
p54
(dp55
g37
g36
sg21
g20
sg27
g26
sg35
g34
sg25
g24
sg31
g30
sg33
g32
sg47
g46
sg49
g48
sg51
g50
sg23
g22
sg19
g18
sg45
g44
sg17
g16
sg43
g42
sg41
g40
sg39
g38
sg29
g28
ssS'info'
p56
(dp57
S'LANG'
p58
g34
ssS'map'
p59
(dp60
g37
S'iso15'
sg21
S'iso05'
sg27
S'koi8-r'
sg35
S'None'
sg25
S'iso02'
sg31
S'iso15'
sg33
S'iso15'
sg47
S'None'
sg49
S'iso02'
sg51
S'iso02'
sg23
S'None'
sg19
S'iso09'
sg45
S'iso02'
sg17
S'None'
sg43
S'koi8-u'
sg41
S'iso02'
sg39
S'iso15'
sg29
S'iso15'
ssS'lang'
p61
g34
sbsS'fstab'
p62
NsS'lilo'
p63
(ililo
LiloConfiguration
p64
(dp65
S'liloDevice'
p66
S'partition'
p67
sS'initrdsMade'
p68
(dsS'edd'
p69
I0
sS'default'
p70
NsS'liloImages'
p71
(dsS'liloLinear'
p72
I0
sS'liloAppend'
p73
NsbsS'comps'
p74
NsS'network'
p75
(itodo
Network
(dp76
S'netdevices'
p77
(dp78
S'eth0'
p79
(itodo
NetworkDevice
(dp80
g56
(dp81
S'ONBOOT'
p82
S'yes'
sS'BOOTPROTO'
p83
S'dhcp'
p84
sS'DEVICE'
p85
g79
ssbssS'gateway'
p86
S''
sS'secondaryNS'
p87
S''
sS'hostname'
p88
S'localhost.localdomain'
p89
sS'primaryNS'
p90
S''
sS'domains'
p91
(lsS'isConfigured'
p92
I1
sS'readData'
p93
I1
sS'ternaryNS'
p94
S''
sbsS'upgrade'
p95
I0
sS'instClass'
p96
(ikickstart
KickstartBase
p97
(dp98
S'postScripts'
p99
(lp100
(ikickstart
Script
(dp101
S'script'
p102
S''
sS'inChroot'
p103
I1
sS'interp'
p104
S'/bin/sh'
p105
sbasS'rootPasswordCrypted'
p106
I1
sS'nameserver'
p107
S''
sS'x'
(ixf86config
XF86Config
p108
(dp109
S'monlist'
p110
(dsS'keyModel'
p111
S'pc101'
p112
sS'monids'
p113
(dsS'device'
p114
NsS'monEisa'
p115
NsS'server'
p116
S'XF86_Mach64'
sS'monHoriz'
p117
S'31.5'
p118
sS'devID'
p119
S'ATI Mach64'
p120
sS'descr'
p121
S'ATI|3D Rage IIC 215IIC [Mach64 GT IIC]'
p122
sS'modes'
p123
(dp124
S'8'
(lp125
S'640x480'
p126
assS'keyOptions'
p127
S''
sS'keyVariant'
p128
S''
sS'monID'
p129
S'Unprobed Monitor'
p130
sS'keyLayout'
p131
S'us'
p132
sS'manualModes'
p133
(dsS'mouse'
p134
(imouse
Mouse
p135
(dp136
g114
S'psaux'
p137
sg56
(dp138
S'XMOUSETYPE'
p139
S'PS/2'
p140
sS'FULLNAME'
p141
S'Generic - 2 Button Mouse (PS/2)'
p142
sS'MOUSETYPE'
p143
S'ps/2'
p144
ssS'emu'
p145
I0
sS'wasProbed'
p146
I1
sS'emulate'
p147
I0
sbsS'keyRules'
p148
S'xfree86'
p149
sS'monVert'
p150
S'60'
p151
sS'cardMan'
p152
S'ATI MACH64'
p153
sS'monSect'
p154
S''
sS'primary'
p155
I0
sS'vidRam'
p156
S'4096'
sS'probed'
p157
I1
sS'monName'
p158
NsS'vidCards'
p159
(lp160
(dp161
S'SERVER'
S'Mach64'
sS'UNSUPPORTED'
S''
sS'DRIVER'
S'ati'
sS'NOCLOCKPROBE'
S''
sS'NAME'
g120
sS'VENDOR'
p162
g153
sS'CHIPSET'
S'ATI-Mach64'
sasS'skip'
p163
I0
sS'files'
p164
S'\012# The location of the RGB database.  Note, this is the name of 
the\012# file minus the extension (like ".txt" or ".db").  There is 
normally\012# no need to change the default.\012\012    
RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are 
allowed (they are concatenated together)\012# By default, Red Hat 6.0 and 
later now use a font server independent of\012# the X server to render 
fonts.\012\012    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType"\012    
FontPath   "unix/:7100"\012'
p165
sbsS'rootPassword'
p166
S'$1$RnG8Z7R7$F8yTwm8CBt7cSW6JH6wIH.'
p167
sS'makeBootdisk'
p168
I0
sS'installType'
p169
S'install'
p170
sS'postScript'
p171
NsS'earlySwapOn'
p172
I1
sS'networkDevice'
p173
NsS'preScripts'
p174
(lsS'clearText'
p175
Nsg63
(g67
I0
Ntsg12
S'en_US'
sS'name'
p176
S''
sS'postInChroot'
p177
I0
sS'pixmap'
p178
S''
sS'partitions'
p179
(lp180
(S'swap'
p181
(I128
I-1
I0
t(S''
I0
I0
t(I0
I0
tNtasS'clearType'
p182
S'wkst'
p183
sg86
S''
sg134
(g142
NI0
tsS'packages'
p184
(lp185
S'kbdconfig'
aS'sash'
aS'libpng'
aS'krb5-devel'
aS'cpp'
aS'filesystem'
aS'ghostscript-fonts'
aS'e2fsprogs'
aS'slrn'
aS'gpm'
aS'diffutils'
aS'strace'
aS'portmap'
aS'eject'
aS'mkkickstart'
aS'zlib-devel'
aS'man'
aS'slang'
aS'losetup'
aS'pmake'
aS'readline'
aS'nmh'
aS'pspell'
aS'ncompress'
aS'libtool'
aS'openldap'
aS'stylesheets'
aS'anacron'
aS'redhat-release'
aS'rwho'
aS'emacs-nox'
aS'tcsh'
aS'cracklib-dicts'
aS'stat'
aS'rhn_register'
aS'pam'
aS'ipchains'
aS'which'
aS'linuxconf'
aS'vixie-cron'
aS'slang-devel'
aS'gettext'
aS'vim-common'
aS'python-devel'
aS'lilo'
aS'mt-st'
aS'mod_ssl'
aS'gcc'
aS'mpage'
aS'crontabs'
aS'inews'
aS'texinfo'
aS'chkconfig'
aS'ypbind'
aS'file'
aS'at'
aS'whois'
aS'logrotate'
aS'pump'
aS'mailx'
aS'diffstat'
aS'tar'
aS'arpwatch'
aS'ypserv'
aS'stunnel'
aS'procps'
aS'autoconf'
aS'newt-devel'
aS'lynx'
aS'gnupg'
aS'XFree86-xfs'
aS'libtiff-devel'
aS'netpbm'
aS'initscripts'
aS'rmt'
aS'dev'
aS'cvs'
aS'rusers'
aS'zlib'
aS'mount'
aS'mkbootdisk'
aS'nfs-utils'
aS'rpm-python'
aS'readline-devel'
aS'grep'
aS'info'
aS'rp-pppoe'
aS'utempter'
aS'chkfontpath'
aS'tcp_wrappers'
aS'LPRng'
aS'hdparm'
aS'authconfig'
aS'ntsysv'
aS'telnet'
aS'bzip2'
aS'rsh-server'
aS'ncurses'
aS'python'
aS'traceroute'
aS'cproto'
aS'glib'
aS'cracklib'
aS'talk'
aS'tcpdump'
aS'groff'
aS'ctags'
aS'dev86'
aS'urw-fonts'
aS'timeconfig'
aS'groff-perl'
aS'm4'
aS'bdflush'
aS'rootfiles'
aS'mktemp'
aS'yp-tools'
aS'libstdc++-devel'
aS'byacc'
aS'ppp'
aS'vim-minimal'
aS'rpm'
aS'perl'
aS'rsh'
aS'kudzu-devel'
aS'shapecfg'
aS'libstdc++'
aS'kernel-smp'
aS'glibc-devel'
aS'libtiff'
aS'mkinitrd'
aS'ncurses-devel'
aS'kudzu'
aS'modutils'
aS'sgml-common'
aS'ltrace'
aS'binutils'
aS'tftp-server'
aS'lsof'
aS'mouseconfig'
aS'slocate'
aS'netpbm-devel'
aS'ghostscript'
aS'bind-utils'
aS'setuptool'
aS'time'
aS'openssl'
aS'wu-ftpd'
aS'njamd'
aS'rdist'
aS'openssh'
aS'libjpeg-devel'
aS'sh-utils'
aS'indent'
aS'talk-server'
aS'metamail'
aS'vim-enhanced'
aS'bash'
aS'MAKEDEV'
aS'ash'
aS'apache'
aS'sysstat'
aS'kernel-headers'
aS'rdate'
aS'passwd'
aS'raidtools'
aS'gawk'
aS'procmail'
aS'cyrus-sasl'
aS'screen'
aS'sendmail'
aS'gcc-c++'
aS'vim-X11'
aS'openjade'
aS'links'
aS'kernel-pcmcia-cs'
aS'wvdial'
aS'gzip'
aS'console-tools'
aS'sgml-tools'
aS'finger'
aS'rwall-server'
aS'XFree86-Mach64'
aS'ed'
aS'shadow-utils'
aS'automake'
aS'openssl-devel'
aS'ucd-snmp'
aS'indexhtml'
aS'bzip2-devel'
aS'bc'
aS'openssh-server'
aS'pidentd'
aS'rsync'
aS'ftp'
aS'mailcap'
aS'tcl'
aS'telnet-server'
aS'python-xmlrpc'
aS'newt'
aS'ucd-snmp-utils'
aS'setserial'
aS'libtermcap'
aS'gpm-devel'
aS'sed'
aS'docbook'
aS'fetchmail'
aS'db2'
aS'cpio'
aS'dump'
aS'rhs-printfilters'
aS'termcap'
aS'gcc-g77'
aS'dip'
aS'libpng-devel'
aS'man-pages'
aS'pine'
aS'rusers-server'
aS'net-tools'
aS'statserial'
aS'bison'
aS'psmisc'
aS'krb5-libs'
aS'patch'
aS'tin'
aS'isdn4k-utils'
aS'minicom'
aS'rpm-build'
aS'libjpeg'
aS'trn'
aS'rcs'
aS'aspell'
aS'emacs'
aS'elm'
aS'dhcpcd'
aS'gdbm-devel'
aS'apmd'
aS'util-linux'
aS'db3'
aS'textutils'
aS'db1'
aS'words'
aS'pwdb'
aS'SysVinit'
aS'cdecl'
aS'kernel'
aS'XFree86-libs'
aS'pnm2ppa'
aS'libtermcap-devel'
aS'gd-devel'
aS'redhat-logos'
aS'freetype'
aS'flex'
aS'iptables'
aS'gmp'
aS'up2date'
aS'kernel-utils'
aS'isapnptools'
aS'sharutils'
aS'urlview'
aS'mod_perl'
aS'rpm-devel'
aS'make'
aS'pciutils'
aS'sysklogd'
aS'glibc'
aS'finger-server'
aS'lrzsz'
aS'mingetty'
aS'tmpwatch'
aS'setup'
aS'anonftp'
aS'gdbm'
aS'quota'
aS'fileutils'
aS'popt'
aS'mutt'
aS'findutils'
aS'pciutils-devel'
aS'gd'
aS'gdb'
aS'iproute'
aS'linuxconf-devel'
aS'basesystem'
aS'iputils'
aS'less'
aS'xinetd'
aS'ncftp'
aS'libtool-libs'
aS'openssh-clients'
asS'timezone'
p186
(S'Etc/GMT-6'
p187
I0
I0
tp188
sS'zeroMbr'
p189
I1
sS'keyboard'
p190
S'us'
p191
sS'groups'
p192
(lsS'bootProto'
p193
g84
sS'netmask'
p194
S''
sS'raidList'
p195
(lsS'skipSteps'
p196
(dp197
S'accounts'
p198
I1
sg134
I1
sg186
I1
sg190
I1
sg75
I1
sS'xconfig'
p199
I1
sS'authentication'
p200
I1
sS'package-selection'
p201
I1
sg11
I1
sS'welcome'
p202
I1
sg63
I1
sg12
I1
sS'confirm-install'
p203
I1
sS'custom-upgrade'
p204
I1
ssS'auth'
p205
(I1
I0
I0
NI0
NI0
I0
NNI0
NNNI0
NNtsg88
Nsg62
(lsS'showgroups'
p206
NsS'ip'
p207
NsS'defaultRunlevel'
p208
NsS'desktop'
p209
S''
sS'clearPartText'
p210
NsS'clearParts'
p211
I2
sbsS'rootpassword'
p212
NsS'extraModules'
p213
(lp214
sg134
g135
sS'ddruidAlreadySaved'
p215
I0
sS'serial'
p216
I0
sg186
g188
sg189
I1
sg190
(ikbd
Keyboard
(dp217
S'layout'
p218
NsS'model'
p219
NsS'type'
p220
S'PC'
p221
sg56
(dp222
S'KEYBOARDTYPE'
p223
S'pc'
p224
sS'KEYTABLE'
p225
g191
ssbsS'skipFdisk'
p226
I1
sS'fdDevice'
p227
S'fd0'
p228
sS'installSystem'
p229
I1
sS'setupFilesystems'
p230
I1
sg205
(itodo
Authentication
(dp231
S'useNIS'
p232
I0
sS'nisServer'
p233
NsS'useLdap'
p234
I0
sS'krb5Kdc'
p235
NsS'useHesiod'
p236
I0
sS'ldapServer'
p237
NsS'nisDomain'
p238
NsS'krb5Realm'
p239
NsS'useLdapauth'
p240
I0
sS'hesiodRhs'
p241
NsS'useShadow'
p242
I1
sS'nisuseBroadcast'
p243
I0
sS'useKrb5'
p244
I0
sS'useMD5'
p245
I0
sS'ldapBasedn'
p246
NsS'krb5Admin'
p247
NsS'hesiodLhs'
p248
NsS'hesiodDlhs'
p249
S''
sbsg88
NsS'reconfigOnly'
p250
I0
sS'x'
g108
sS'users'
p251
NsS'instPath'
p252
S'/mnt/sysimage'
p253
sS'intf'
p254
NsS'hdList'
p255
Nsb.
Comment 1 Michael Fulbright 2001-02-13 23:04:19 EST

*** This bug has been marked as a duplicate of 18648 ***

Note You need to log in before you can comment on or make changes to this bug.