Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 27436 - 3rd party java (IBM/Sun jre's) crash and burn
3rd party java (IBM/Sun jre's) crash and burn
Status: CLOSED DUPLICATE of bug 27003
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 14:56 EST by Chris Chabot
Modified: 2016-11-24 09:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-15 18:09:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Chabot 2001-02-13 14:56:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i686)


When running a 3rd party Java runtime env, it crashes and burns. The Sun
JRE doesnt give any errors, but the IBM jre shows the folowing output:
java.lang.StackOverflowError
        at
sun.awt.image.GifImageDecoder.readImage(GifImageDecoder.java:548)
        at
sun.awt.image.GifImageDecoder.produceImage(GifImageDecoder.java:227)
        at
sun.awt.image.InputStreamImageSource.doFetch(InputStreamImageSource.java:268)
        at sun.awt.image.ImageFetcher.fetchloop(ImageFetcher.java:221)
        at sun.awt.image.ImageFetcher.run(ImageFetcher.java:189)

i ran into this problem while trying to install any and all of these
packages:
	jedit (opensource)
	zenddebugger
	altavista search engine
zend debugger & altavista wont run under kaffe,
so i would imagine, any other java based (or jre including such as
altavista search) wont run on the current 7.1 series..
The GIF encoder error, leads me to believe it might be a X problem?


Reproducible: Always
Steps to Reproduce:
1. Install RPM's for IBM JRE2 1.3 
2. include jre/bin in $PATH
3. install jedit / altavista search (trial avail) or zend debugger client
4. run the java program.. *boom*

	

Actual Results:  in IBM's jre:
java.lang.StackOverflowError
        at
sun.awt.image.GifImageDecoder.readImage(GifImageDecoder.java:548)
        at
sun.awt.image.GifImageDecoder.produceImage(GifImageDecoder.java:227)
        at
sun.awt.image.InputStreamImageSource.doFetch(InputStreamImageSource.java:268)
        at sun.awt.image.ImageFetcher.fetchloop(ImageFetcher.java:221)
        at sun.awt.image.ImageFetcher.run(ImageFetcher.java:189)
java.lang.StackOverflowError
        at sun.io.CharacterEncoding.<clinit>(CharacterEncoding.java)
        at java.awt.image.Raster.createInterleavedRaster(Raster.java:226)
        at
java.awt.image.IndexColorModel.createCompatibleWritableRaster(IndexColorModel.java:1153)
        at
sun.awt.image.ImageRepresentation.createBufferedImage(ImageRepresentation.java:226)
        at
sun.awt.image.ImageRepresentation.setDimensions(ImageRepresentation.java:143)
        at sun.awt.image.ImageDecoder.setDimensions(ImageDecoder.java:69)
        at
sun.awt.image.GifImageDecoder.readImage(GifImageDecoder.java:555)
        at
sun.awt.image.GifImageDecoder.produceImage(GifImageDecoder.java:227)
        at
sun.awt.image.InputStreamImageSource.doFetch(InputStreamImageSource.java:268)
        at sun.awt.image.ImageFetcher.fetchloop(ImageFetcher.java:221)
        at sun.awt.image.ImageFetcher.run(ImageFetcher.java:189)

sun's JRE just hangs, does nothing	

Expected Results:  program should start..
Comment 1 Bill Nottingham 2001-02-13 18:42:08 EST
If you install the i386 glibc package, does it start working?
Comment 2 Chris Chabot 2001-02-14 01:58:05 EST
> If you install the i386 glibc package, does it start working?

if i rpm -ivh --force the glibc i386 package, IBM's JRE does start working!
however sun's JRE still suffers the same fate (hangs, no output or javacore
dump)

ps, rpm -e glibc ; rpm -ivh glibc-..i386 can cause u to have to reinstall ur
system i noticed, thus the testing took a while :)

Comment 3 Glen Foster 2001-02-15 18:09:08 EST
We (Red Hat) should really try to resolve this before next release.
Comment 4 Trond Eivind Glomsrxd 2001-02-26 21:00:59 EST

*** This bug has been marked as a duplicate of 27003 ***

Note You need to log in before you can comment on or make changes to this bug.