Bug 27003 - Sun's Java 2 1.3 broken
Sun's Java 2 1.3 broken
Status: CLOSED DUPLICATE of bug 27090
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 27436 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-10 20:46 EST by Gerald Henriksen
Modified: 2016-11-24 09:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 21:00:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Henriksen 2001-02-10 20:46:24 EST
java -version gives:

/opt $ java -version
/opt/jdk/bin/java: /usr/bin/cut: No such file or directory
/opt/jdk1.3/bin/i386/native_threads/java: error while loading shared
libraries: libjvm.so: cannot load shared object file: No such file or
directory

Same error when calling javac

This version of Java worked fine on 7.0 Guiness
Comment 1 Bill Nottingham 2001-02-11 03:08:17 EST
Assigning to glibc, but it looks very likely that your ld.so.conf
is screwed up.
Comment 2 Need Real Name 2001-02-12 05:20:41 EST
I have had the same problem. I linked /bin/cut as /usr/bin/cut and the error 
message disappeared, but java does not work yet.
a.gargantini@unict.it
Comment 3 Glen Foster 2001-02-12 18:14:09 EST
We (Red Hat) should really try to resolve this before next release.
Comment 4 Need Real Name 2001-02-13 12:23:16 EST
I have determined that this has something to do with glibc-2.2.1-3.i686:

When I forced the installation of glibc-2.2.1-3.i386.rpm, java started to
"work".  Threads do NOT behave like threads, though (basically, there's no
threading).

java -version reports:
java version "1.3.0"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.0)
Java HotSpot(TM) Client VM (build 1.3.0, mixed mode)

The use of glibc-2.2.1-3.i686.rpm does work for Java SDK, version 1.3.0, when
using the (now obsolete) Classic VM (green-threads, no jit).

NOTE:  This is the motherboard/processor I am running:
ASUS A7V (no audio) motherboard
Athlon Thunderbird Socket-A processor, 850MHz
128MB SDRAM (PC-133)
IBM Deskstar G30X 30GB HDD (ATA-100)

I hope this helps...
Comment 5 Trond Eivind Glomsrxd 2001-02-26 20:58:44 EST
The reason is (probably) the use of an assumption that the thread stack space is
2 MB. This is a duplicate of something... searching.
Comment 6 Trond Eivind Glomsrxd 2001-02-26 21:00:55 EST
*** Bug 27436 has been marked as a duplicate of this bug. ***
Comment 7 Trond Eivind Glomsrxd 2001-02-26 21:31:35 EST

*** This bug has been marked as a duplicate of 27090 ***

Note You need to log in before you can comment on or make changes to this bug.