This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 274681 - TB4303b6e5 boot_gui.py:30:<module>:ImportError: No module named firstboot_module_window
TB4303b6e5 boot_gui.py:30:<module>:ImportError: No module named firstboot_mod...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-boot (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: bogotano (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-02 16:13 EDT by Pablo DCristofaro
Modified: 2008-04-08 05:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 05:39:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
BootLoaderDump.txt (6.41 KB, text/plain)
2008-02-10 00:16 EST, David Filiatrault
no flags Details

  None (edit)
Description Pablo DCristofaro 2007-09-02 16:13:23 EDT
Description of problem:


Version-Release number of selected component (if applicable):Version: 0.2.15


How reproducible:


Steps to Reproduce:
1. System - Administration - Bootloader
2.
3.
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/system-config-boot/system-config-boot.py", line 80, in <module>
    import boot_gui
  File "/usr/share/firstboot/modules/boot_gui.py", line 30, in <module>
    from firstboot_module_window import FirstbootModuleWindow
ImportError: No module named firstboot_module_window

Local variables in innermost frame:
string: None
kudzu: None
__builtins__: {'IndexError': <type 'exceptions.IndexError'>, 'all': <built-in
function all>, 'help': Type help() for interactive help, or help(object) for
help about object., 'vars': <built-in function vars>, 'SyntaxError': <type
'exceptions.SyntaxError'>, 'unicode': <type 'unicode'>, 'UnicodeDecodeError':
<type 'exceptions.UnicodeDecodeError'>, 'isinstance': <built-in function
isinstance>, 'copyright': Copyright (c) 2001-2006 Python Software Foundation.
All Rights Reserved.

Copyright (c) 2000 BeOpen.com.
All Rights Reserved.

Copyright (c) 1995-2001 Corporation for National Research Initiatives.
All Rights Reserved.

Copyright (c) 1991-1995 Stichting Mathematisch Centrum, Amsterdam.
All Rights Reserved., 'NameError': <type 'exceptions.NameError'>, 'dict': <type
'dict'>, 'input': <built-in function input>, 'oct': <built-in function oct>,
'SystemExit': <type 'exceptions.SystemExit'>, 'StandardError': <type
'exceptions.StandardError'>, 'repr': <built-in function repr>, 'sorted':
<built-in function sorted>, 'False': False, 'RuntimeWarning': <type
'exceptions.RuntimeWarning'>, 'list': <type 'list'>, 'iter': <built-in function
iter>, 'reload': <built-in function reload>, 'Warning': <type
'exceptions.Warning'>, 'round': <built-in function round>, 'dir': <built-in
function dir>, 'cmp': <built-in function cmp>, 'set': <type 'set'>, 'reduce':
<built-in function reduce>, 'intern': <built-in function intern>, 'issubclass':
<built-in function issubclass>, 'Ellipsis': Ellipsis, 'EOFError': <type
'exceptions.EOFError'>, 'locals': <built-in function locals>, 'slice': <type
'slice'>, 'FloatingPointError': <type 'exceptions.FloatingPointError'>, 'sum':
<built-in function sum>, 'getattr': <built-in function getattr>, 'abs':
<built-in function abs>, 'exit': Use exit() or Ctrl-D (i.e. EOF) to exit,
'True': True, 'FutureWarning': <type 'exceptions.FutureWarning'>,
'ImportWarning': <type 'exceptions.ImportWarning'>, 'None': None, 'hash':
<built-in function hash>, 'len': <built-in function len>, 'credits':     Thanks
to CWI, CNRI, BeOpen.com, Zope Corporation and a cast of thousands
    for supporting Python development.  See www.python.org for more
information., 'frozenset': <type 'frozenset'>, '__name__': '__builtin__', 'ord':
<built-in function ord>, 'super': <type 'super'>, '_': <bound method
i18n.gettext of <rhpl.translate.i18n instance at 0xb7c7420c>>, 'TypeError':
<type 'exceptions.TypeError'>, 'license': See
http://www.python.org/2.5/license.html, 'KeyboardInterrupt': <type
'exceptions.KeyboardInterrupt'>, 'UserWarning': <type 'exceptions.UserWarning'>,
'filter': <built-in function filter>, 'range': <built-in function range>,
'staticmethod': <type 'staticmethod'>, 'SystemError': <type
'exceptions.SystemError'>, 'BaseException': <type 'exceptions.BaseException'>,
'pow': <built-in function pow>, 'RuntimeError': <type
'exceptions.RuntimeError'>, 'float': <type 'float'>, 'MemoryError': <type
'exceptions.MemoryError'>, 'StopIteration': <type 'exceptions.StopIteration'>,
'globals': <built-in function globals>, 'divmod': <built-in function divmod>,
'enumerate': <type 'enumerate'>, 'apply': <built-in function apply>,
'LookupError': <type 'exceptions.LookupError'>, 'open': <built-in function
open>, 'quit': Use quit() or Ctrl-D (i.e. EOF) to exit, 'basestring': <type
'basestring'>, 'UnicodeError': <type 'exceptions.UnicodeError'>, 'zip':
<built-in function zip>, 'hex': <built-in function hex>, 'long': <type 'long'>,
'ReferenceError': <type 'exceptions.ReferenceError'>, 'ImportError': <type
'exceptions.ImportError'>, 'chr': <built-in function chr>, 'xrange': <type
'xrange'>, 'type': <type 'type'>, '__doc__': "Built-in functions, exceptions,
and other objects.\n\nNoteworthy: None is the `nil' object; Ellipsis represents
`...' in slices.", 'Exception': <type 'exceptions.Exception'>, 'tuple': <type
'tuple'>, 'UnicodeTranslateError': <type 'exceptions.UnicodeTranslateError'>,
'reversed': <type 'reversed'>, 'UnicodeEncodeError': <type
'exceptions.UnicodeEncodeError'>, 'IOError': <type 'exceptions.IOError'>,
'hasattr': <built-in function hasattr>, 'delattr': <built-in function delattr>,
'setattr': <built-in function setattr>, 'raw_input': <built-in function
raw_input>, 'SyntaxWarning': <type 'exceptions.SyntaxWarning'>, 'compile':
<built-in function compile>, 'ArithmeticError': <type
'exceptions.ArithmeticError'>, 'str': <type 'str'>, 'property': <type
'property'>, 'GeneratorExit': <type 'exceptions.GeneratorExit'>, 'int': <type
'int'>, '__import__': <built-in function __import__>, 'KeyError': <type
'exceptions.KeyError'>, 'coerce': <built-in function coerce>,
'PendingDeprecationWarning': <type 'exceptions.PendingDeprecationWarning'>,
'file': <type 'file'>, 'EnvironmentError': <type 'exceptions.EnvironmentError'>,
'unichr': <built-in function unichr>, 'any': <built-in function any>, 'OSError':
<type 'exceptions.OSError'>, 'DeprecationWarning': <type
'exceptions.DeprecationWarning'>, 'min': <built-in function min>,
'UnicodeWarning': <type 'exceptions.UnicodeWarning'>, 'execfile': <built-in
function execfile>, 'id': <built-in function id>, 'complex': <type 'complex'>,
'bool': <type 'bool'>, 'ValueError': <type 'exceptions.ValueError'>,
'NotImplemented': NotImplemented, 'map': <built-in function map>, 'buffer':
<type 'buffer'>, 'max': <built-in function max>, 'object': <type 'object'>,
'TabError': <type 'exceptions.TabError'>, 'callable': <built-in function
callable>, 'ZeroDivisionError': <type 'exceptions.ZeroDivisionError'>, 'eval':
<built-in function eval>, '__debug__': True, 'IndentationError': <type
'exceptions.IndentationError'>, 'AssertionError': <type
'exceptions.AssertionError'>, 'classmethod': <type 'classmethod'>,
'UnboundLocalError': <type 'exceptions.UnboundLocalError'>,
'NotImplementedError': <type 'exceptions.NotImplementedError'>,
'AttributeError': <type 'exceptions.AttributeError'>, 'OverflowError': <type
'exceptions.OverflowError'>}
__file__: None
gtk: None
sys: None
N_: None
gobject: None
__name__: None
os: None
__doc__: None
_: None



Expected results:


Additional info:
Comment 1 Harald Hoyer 2007-09-20 08:51:09 EDT
What does:
$ rpm -qf /usr/share/firstboot/firstboot_module_window.py
$ rpm -qi firstboot
output??

system-config-boot requires firstboot, so something must be broken. Maybe fixed
best with:
# yum install firstboot
Comment 2 Pablo DCristofaro 2007-09-24 22:16:04 EDT
With # yum install firstboot I could fix the error.
Thank!!!
Comment 3 Deji Akingunola 2007-11-30 14:29:12 EST
This same traceback in OP is now back for real in rawhide - because of changes
in firstboot, I guess. This is with system-config-boot-0.2.17 and
firstboot-1.90-2.fc9.
Comment 4 David Filiatrault 2008-02-10 00:16:49 EST
Created attachment 294484 [details]
BootLoaderDump.txt
Comment 5 petrosyan 2008-04-07 14:00:23 EDT
I can not reproduce this bug in rawhide with
firstboot-1.95-3.fc9.x86_64
system-config-boot-0.2.19-1.fc9.x86_64

Is anybody still seeing this bug?
Comment 6 petrosyan 2008-04-07 14:03:47 EDT
*** Bug 433393 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.