Bug 275071 - metacity crashes (related to session management?)
metacity crashes (related to session management?)
Status: CLOSED DUPLICATE of bug 243761
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-03 07:26 EDT by Jeff Garzik
Modified: 2014-06-18 05:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-11 13:39:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff Garzik 2007-09-03 07:26:59 EDT
Description of problem:
After upgrading from Fedora Core 6 to Fedora 7 (i.e. not a new install), I
removed all dotfiles (and "dotdirs") I could find related to GNOME, gtk, KDE,
X11, etc. in my home directory.

Then I rebooted (thus initiating login via gdm).

I logged on, and it gave me a fresh desktop (expected behavior).  I configured
my panel, my favorite layout of gnome terminals, turned on session management,
logged out, and logged back in (NOT reboot).

After logging in, my desktop background appears along with all my gnome
terminals...  all in the same screen.  No windows have decorations.  I run
"metacity &" in a shell, and suddenly the rest of the desktop appears.

Fiddling with session management seems to produce different behaviors, but since
I run with session management enabled (save/restore windows upon logoff/login),
this is a 100% reproducible behavior for me.

My normal desktop setup consists of nine workspaces, each with 2-3 gnome
terminals... except for two web browsing workspaces and an IRC workspace.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
0. remove all gnome/gtk/x/kde/etc. dotfiles from home directory, including any
default ones that 'useradd' may have installed for you.
1. set up a bunch of terminals in multiple workspaces.  run browser, xchat,
2. log out.
3. log in.
Actual results:
need to run window manager manually to restore operation, so I --assume-- it
crashed upon login.

Expected results:
a running window manager :)

Additional info:
Comment 1 P Jones 2007-09-05 12:49:31 EDT
If you run gnome-session, does it list metacity in the startup programs section?
Comment 2 Jeff Garzik 2007-09-05 15:14:48 EDT
If I run gnome-session, it complains that I already have a gnome-session
running.  Is it OK to kill?

If I run gnome-session-properties, metacity is not listed in the 'Additional
Startup Programs' section.
Comment 3 Ray Strode [halfline] 2007-09-11 13:39:52 EDT

*** This bug has been marked as a duplicate of 243761 ***

Note You need to log in before you can comment on or make changes to this bug.