Bug 243761 - metacity fails to start at login
metacity fails to start at login
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
: Reopened
: 275071 286381 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-06-11 14:56 EDT by Keith Dixon
Modified: 2014-06-18 05:09 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.18.5-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-18 10:02:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
requested session file (3.45 KB, text/plain)
2007-09-10 13:08 EDT, Keith Dixon
no flags Details
requested metacity session file (971 bytes, text/plain)
2007-09-11 02:46 EDT, Keith Dixon
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 433253 None None None Never

  None (edit)
Description Keith Dixon 2007-06-11 14:56:11 EDT
Description of problem:
Since an update, on 10th June,the window manager, metacity, has failed to start
at login.  I can start it by typing metacity& in a terminal.  In addition, I
have xemacs, a non-session-managed application, configured to start at login. 
When shutting down, the dialog, warning of non-session-managed applications, no
longer appears.  I have not yet discovered which package caused the problem but
it would appear to be a problem in the session manager.

Version-Release number of selected component (if applicable):
The updated packages were:-
Jun 10 06:43:47 Updated: gtk2.i386 2.10.12-2.fc7
Jun 10 06:43:53 Updated: gnome-desktop.i386 2.18.2-1.fc7
Jun 10 06:43:55 Updated: gnome-menus.i386 2.18.2-1.fc7
Jun 10 06:44:59 Updated: gnome-panel.i386 2.18.2-2.fc7
Jun 10 06:45:12 Updated: gtk2-devel.i386 2.10.12-2.fc7
Jun 10 06:45:16 Updated: samba-common.i386 3.0.25a-3.fc7
Jun 10 06:46:26 Updated: gnome-utils.i386 2.18.1-1.fc7
Jun 10 06:46:31 Updated: vte.i386 0.16.5-1.fc7
Jun 10 06:47:20 Updated: nautilus-cd-burner.i386 2.18.2-1.fc7
Jun 10 06:48:08 Updated: metacity.i386 2.18.3-1.fc7
Jun 10 06:48:10 Updated: gnome-mag.i386 0.14.4-1.fc7
Jun 10 06:48:56 Updated: gnome-session.i386 2.18.2-1.fc7
Jun 10 06:49:19 Updated: gnome-screensaver.i386 2.18.2-1.fc7
Jun 10 06:50:04 Updated: gnome-system-monitor.i386 2.18.2-1.fc7
Jun 10 06:50:05 Updated: gnome-desktop-devel.i386 2.18.2-1.fc7
Jun 10 06:51:13 Updated: gnome-games.i386 2.18.2-1.fc7
Jun 10 06:51:14 Updated: gtk2-engines.i386 2.10.2-2.fc7
Jun 10 06:51:15 Updated: libsmbclient.i386 3.0.25a-3.fc7
Jun 10 06:51:32 Updated: gdm.i386 2.18.2-1.fc7
Jun 10 06:51:34 Updated: samba-client.i386 3.0.25a-3.fc7
Jun 10 06:52:07 Updated: file-roller.i386 2.18.3-1.fc7
Jun 10 06:53:03 Updated: eog.i386 2.18.2-2.fc7
Jun 10 06:53:03 Updated: gnome-panel-devel.i386 2.18.2-2.fc7
Jun 10 06:53:05 Updated: xdg-user-dirs.i386 0.8-3.fc7

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Is this related to Bug 243650: Gnome logout hangs follwing last set of gtk and
gnome updates?
Comment 1 Need Real Name 2007-06-12 14:46:05 EDT
I see the same problem after upgrading on 12-6-2007, no window manager active
after login.
I started metacity manually, and closed all my session tasks (terminal's,
calculator, openoffice) then I logged off, and re-logged in, and the problem has
Also after re-starting the old sessions, and re-login everything remains fine.
So it was something with the session administration.

Hope this helps,
Comment 2 Keith Dixon 2007-06-12 16:53:59 EDT
Thanks for the suggestions phjvdmeij.  You prompted me to do a little more
investigation.  The problem seems to be caused by selecting:-
"Automatically save changes to session"
System->Preferences->Personal->Sessions->Session Options

Deselecting this and clicking on "Save the current session" seems to solve the
problem.  Select it and the problem returns again.  I would be interested if you
see the same behaviour.

The dialog warning of non-session-managed applications still does not appear but
that may be deliberate.  I never could see the point of it when a program was
started automatically.
Comment 3 Need Real Name 2007-06-15 15:21:43 EDT
I tried what you suggested, but I can not re-produce the problem.
I did see the problem a couple of days ago once more, and again solved it by
deleting that session (Openoffice calc, if that had anything to do with the problem)

Sorry for the late reaction
Comment 4 Jonathan Kamens 2007-07-01 16:29:02 EDT
This is happening to me with raw hide current as of today.  Metacity doesn't
start on logon even if I make sure it's running in the sessions dialog and then
save my current session state before logging out.  Once I start it by hand it
seems to beo work just fine.
Comment 5 Brian Morrison 2007-09-08 12:30:27 EDT
Exactly the same problem using a fully updated default install of F7 on x86_64.

All the saved session's windows start, but with no window frames and title bars,
making them impossible to move!

Deleting ~/.gnome2/session and restarting gnome fixes this, have not tried
deselecting save session at logout yet.

If any more debugging would help, please indicate which debuginfo rpms would be
useful and how to capture the relevant debug or log information.
Comment 6 Ray Strode [halfline] 2007-09-09 09:40:55 EDT
Have you guys played with "Desktop Effects" at all?

The "Enable Desktop Effects" button starts a different window manager called
compiz.  It could be that this window manager is crashing at startup.
Comment 7 Keith Dixon 2007-09-10 05:35:46 EDT
Hi Ray.  I have never tried to run compiz as I think my machine and graphics
card are not up to it.  I checked System->Preferences->Look and Feel->Desktop
Effects and the options are greyed out, which I presume indicates that compiz is
not selected.  

I also tried, again, selecting "Automatically save changes to session" as per
Comment #2 and metacity failed to start again even though there have been
numerous updates since that comment.  In particular, my current versions are:-

The non-session-managed dialog has not been seen since it first disappeared.
Comment 8 Ray Strode [halfline] 2007-09-10 09:54:01 EDT
can you attach your ~/.gnome2/session file?
Comment 9 Keith Dixon 2007-09-10 13:08:18 EDT
Created attachment 191811 [details]
requested session file
Comment 10 Ray Strode [halfline] 2007-09-10 16:43:29 EDT
Hi Keith,

is that session file from an account that is currently experiencing the problem?

Do you have /home/dixon/.metacity/sessions/1189415444-4008-3683060981.ms ?  Can
you attach it?
Comment 11 Keith Dixon 2007-09-11 02:46:32 EDT
Created attachment 192321 [details]
requested metacity session file

Yes it is, Indeed it is the only account on this machine.
Comment 12 Ray Strode [halfline] 2007-09-11 13:31:34 EDT
*** Bug 286381 has been marked as a duplicate of this bug. ***
Comment 13 Ray Strode [halfline] 2007-09-11 13:39:53 EDT
*** Bug 275071 has been marked as a duplicate of this bug. ***
Comment 14 Ray Strode [halfline] 2007-09-11 15:41:32 EDT
So metacity has this code in it:

  /* don't need to free displays */
  displays = NULL;

and then later on

  timestamp = meta_display_get_current_time_roundtrip (displays->data);

which won't work, since displays is NULL.
Comment 15 Ray Strode [halfline] 2007-09-11 15:45:40 EDT
building metacity-2.18.5-2.fc7 now.

Would any of you guys be willing to test the package in -updates-testing before
it goes out to -updates?
Comment 16 Jeff Garzik 2007-09-11 15:52:47 EDT
If you can provide a direct URL to the RPM(s), I can try it.  The problem is
definitely reproducible here.
Comment 17 Ray Strode [halfline] 2007-09-11 16:03:30 EDT
Before moving the fix for this upstream, I did a quick search of upstream
bugzilla  and found:


A patch was already there, just not committed yet.

The build finished, marking MODIFIED.
Comment 18 Ray Strode [halfline] 2007-09-11 16:05:27 EDT
Hi Jeff,

packages are here:


Or if you have the koji command line utility installed you can do

koji download-build --arch=i386 metacity-2.18.5-2.fc7
Comment 19 Fedora Update System 2007-09-12 12:42:15 EDT
metacity-2.18.5-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Keith Dixon 2007-09-12 13:34:43 EDT
Thanks Ray. That seems to have fixed it. Even the non-session-managed dialog has
Comment 21 Ray Strode [halfline] 2007-09-12 16:43:42 EDT
Okay, thanks for confirming Keith.  I'll request an -updates push.
Comment 22 Fedora Update System 2007-09-17 23:17:57 EDT
metacity-2.18.5-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Jonathan Kamens 2007-09-17 23:21:31 EDT
What about Rawhide?
Comment 24 Ray Strode [halfline] 2007-09-18 10:02:45 EDT
went into rawhide on the 11th.

Note You need to log in before you can comment on or make changes to this bug.