Bug 275181 - syslogd memory leak
syslogd memory leak
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sysklogd (Show other bugs)
4.5
All All
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Brian Brock
:
: 429271 (view as bug list)
Depends On:
Blocks: 399271
  Show dependency treegraph
 
Reported: 2007-09-03 09:53 EDT by Jose Plans
Modified: 2010-10-22 14:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0162
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 12:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
syslogd-memleak-fix.patch (470 bytes, patch)
2007-09-03 09:53 EDT, Jose Plans
no flags Details | Diff

  None (edit)
Description Jose Plans 2007-09-03 09:53:55 EDT
Description of the problem:

syslogd after including the latest patch
"sysklogd-1.4.1-noforward_local_address.patch" introduced a memory leak when
using remote logging.
Everytime the syslogd daemon is restarted, it keeps leaking memory around the
size of ifaddrs and this is because there is a usage of getifaddrs() without
calling then freeifaddrs() to clear the dynamically allocated data.

Version-Release number of selected component (if applicable):
sysklogd-1.4.1-26_EL

How reproducible:
Always

Steps to Reproduce:
1. Setup syslog for remote auditing:
   In remote host change /etc/sysconfig/syslog to get the flag -r.
(SYSLOGD_OPTIONS="-m 0 -r")
   In local host  change /etc/syslog.conf to log into remote (for this case we
used *.info  @remote)
2. Reload syslogd. SIGHUP.
3. Run the following:
   % while true ; do /bin/kill -HUP `pidof syslogd` ; cat /proc/`pidof
syslogd`/status | grep -i vmdata; done
  
Actual results:
         VmData:      148 kB
         VmData:      148 kB
         VmData:      148 kB
         VmData:      796 kB
         VmData:     1696 kB
         VmData:     2588 kB

Expected results:
         VmData:      148 kB
         VmData:      148 kB
         VmData:      148 kB
         VmData:      148 kB
         VmData:      148 kB
         VmData:      148 kB
	 
Additional info:
Patch attached tested and writen by the customer.

Business Impact:

The custmer is using syslogd which configured logging to local files and remote
hosts. This customer's system is heavily logging, therefore logrotate runs every
10 seconds. Since kill -HUP is called when running logrotate, the syslogd's
memory increases swiftly.
Comment 1 Jose Plans 2007-09-03 09:53:57 EDT
Created attachment 185271 [details]
syslogd-memleak-fix.patch
Comment 5 Jose Plans 2008-01-18 09:30:20 EST
*** Bug 429271 has been marked as a duplicate of this bug. ***
Comment 10 errata-xmlrpc 2008-04-09 12:15:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0162.html

Note You need to log in before you can comment on or make changes to this bug.