Bug 27570 - Installer crashes before post-install configuration w/3ware Escalade 6400 IDE RAID controller
Installer crashes before post-install configuration w/3ware Escalade 6400 IDE...
Status: CLOSED DUPLICATE of bug 27550
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Erik Troan
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-02-14 04:23 EST by Nuutti-Iivari Merilainen
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-03 18:17:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nuutti-Iivari Merilainen 2001-02-14 04:23:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22enterprise i686)

I'm using expert installation (with the anaconda update disk) with 'linux
updates expert' at the boot prompt, and everything runs smoothly (the
anaconda update and 3ware driver get loaded) until the very end of the
installation, at which point anaconda crashes with error messages from
Python (see Additional Information).

Granted, the RAID5 support in the Escalade BIOS is rather new (just out).
Nevertheless, this seems to be an anaconda bug rather than a 3ware driver
bug, since installation goes smoothly until anaconda tries to copy the
3ware kernel module.

Reproducible: Always
Steps to Reproduce:
1. Install RH7 with anaconda update disk and 3ware driver disk with 
'linux updates expert' at the boot prompt. Go through installation steps as
necessary, and start the actual install. Before post-install configuration
phase, anaconda crashes
(I assume it tries to copy the 3ware kernel module but doesn't find it and

Actual Results:  Anaconda crashes with Python errors, system reboots
without installing LILO (and most probably without installing the 3ware
driver), rendering the system unusable.

Expected Results:  The 3ware Escalade driver should have been installed as
kernel module and LILO should have been installed (optionally, a boot disk
should have been created).

Here is the traceback from anaconda (saved to disk after the crash from the
error dialog):

------ BEGIN TRACEBACK ------

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
in run
    rc = self.todo.doInstall ()
  File "/tmp/updates/todo.py", line 1649, in doInstall
  File "/tmp/updates/todo.py", line 1367, in copyExtraModules
    os.rename(fromFile, to)
OSError: [Errno 2] No such file or directory

Local variables in innermost frame:
fromFile: /mnt/sysimage/lib/modules/2.2.16-22smp/3w-xxxx.o
kernelVersions: ['2.2.16-22smp', '2.2.16-22']
path: /tmp/modules/3w-xxxx
names:  3w-xxxx.o 3w-xxxx.o
command: cd /mnt/sysimage/lib/modules; gunzip <
 | /mnt/sysimage/bin/cpio  --quiet -iumd  2.2.16-22smp/3w-xxxx.o
version: 2.2.16-22
subdir: scsi
to: /mnt/sysimage/lib/modules/2.2.16-22smp/scsi/3w-xxxx.o
n: 2.2.16-22smp
self: <todo.ToDo instance at 8495720>
pattern:  2.2.16-22smp/3w-xxxx.o 2.2.16-22/3w-xxxx.o
name: 3w-xxxx

ToDo object:


------ END TRACEBACK ------
Comment 1 Nuutti-Iivari Merilainen 2001-02-14 12:53:28 EST
I figured something out: I'm installing everything on a non-SMP system and
anaconda is trying to copy the 3ware module to the 'scsi' directory under SMP
kernel modules. I created the directory (which didn't exists because the SMP
kernel doesn't get installed) and was able to complete the installation. It
works, but it's not too nice. I'll check tomorrow by installing everything and
omitting all SMP-related stuff; but it seems to me that it's either a problem
with anaconda _or_ with the 3ware driver disk assuming that the SMP kernel
module should be installed even if the system isn't SMP.
Comment 2 Erik Troan 2001-04-03 18:01:35 EDT
Fixed for next release.
Comment 3 Matt Wilson 2001-04-03 18:18:36 EDT

*** This bug has been marked as a duplicate of 27550 ***

Note You need to log in before you can comment on or make changes to this bug.