Bug 275821 - qdiskd silently fails to register its node in cman
qdiskd silently fails to register its node in cman
Status: CLOSED DUPLICATE of bug 294351
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All All
medium Severity medium
: ---
: ---
Assigned To: Christine Caulfield
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 04:27 EDT by Alain RICHARD
Modified: 2009-04-16 18:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 02:59:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alain RICHARD 2007-09-04 04:27:09 EDT
Description of problem:

qdiskd fails to register its node with cman when qdisk device name is too long.

Version-Release number of selected component (if applicable):

cman-2.0.64-1.0.1.el5

How reproducible:


100 % reproductible.


Steps to Reproduce:

Configure a qdisk device with a long name. This is very easy when using multipaths devices. For 
example :

/dev/mpath/qdisk1

The problem here is that once it has got a ready state, it tries to register itself as a node in cman in 
order to add its voting scores to the cluster. To do so, it uses the device name as node name.

This hit a limitation in cman where MAX_CLUSTER_NAME_LEN is defined as 16.

Actual results:

qdiskd fails to register its node and its vote score in the cluster, but also do not report any error in the 
different logs (even when starting qdiskd with "qdiskd -f -d"). It was very frustrating to found out what 
was going on as qdiskd logic was good.

At a minimum, qdiskd should be patched in order to return an errors in the log when it fails to register 
its node in cman.

Other approach are possible : define MAX_CLUSTER_NAME_LEN 32 in cman ? use a fixed name for the 
node register by qdiskd ?
Comment 1 Lon Hohberger 2007-09-24 16:53:58 EDT
I think there's a bug against cman which has already been fixed for 5.1; Patrick
was working on it.  The MAX_CLUSTER_NAME_LEN should have been CMAN_MAX_NODENAME_LEN
Comment 2 Christine Caulfield 2007-09-25 02:59:41 EDT
This is fixed in 5.1

*** This bug has been marked as a duplicate of 294351 ***

Note You need to log in before you can comment on or make changes to this bug.