Bug 294351 - qdisk does not run on multipathed /dev/mapper devices.
qdisk does not run on multipathed /dev/mapper devices.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christine Caulfield
GFS Bugs
: Regression
: 275821 (view as bug list)
Depends On:
Blocks: 294711
  Show dependency treegraph
 
Reported: 2007-09-18 03:21 EDT by Wade Mealing
Modified: 2010-10-22 14:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2007-0575
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:59:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Works around length limitation (26.17 KB, patch)
2007-09-18 10:57 EDT, Lon Hohberger
no flags Details | Diff
Patch for review (611 bytes, patch)
2007-09-19 03:18 EDT, Christine Caulfield
no flags Details | Diff

  None (edit)
Description Wade Mealing 2007-09-18 03:21:31 EDT
Description of problem:

This problem exists when accessing/setting the quorum disk by label or by device.

The quorum disk as specified in cluster.conf is unable to work on /dev/mapper
devices.   Customers would like the quorum to be on a robust device.  Although
the quorum can be configured to run on /dev/dm-N, these can change depending on
various san related factors.


Scenario 1:

        <quorumd label="test_qdisk" status_file="/tmp/foo" interval="1"
min_score="1" tko="10" votes="2">
                <heuristic interval="3" program="ping reliable.host.com -c1 -t1"
score="1"/>
        </quorumd>

This is problematic, as the qdisk daemon scans through /proc/filesystems and
grabs the first match (usually the /dev/sde, not /dev/dm-N) which voids the use
case for multipath.

A possible (and tested) is to return the last match in the partition list 
(cman/qdisk/proc.c), not the first, if people have quorum on multipath, the
multipath device is probablyl what they want.


Scenario 2:

     <quorumd device="/dev/mapper/whatever" status_file="/tmp/foo" interval="1"
min_score="1" tko="10" votes="2">
                <heuristic interval="3" program="ping reliable.host.com -c1 -t1"
score="1"/>
        </quorumd>


While this device is found, it is not counted towards the votes in cman_tool status.

Scenario 3:


     <quorumd device="/dev/qvg/qlv" status_file="/tmp/foo" interval="1"
min_score="1" tko="10" votes="2">
                <heuristic interval="3" program="ping reliable.host.com -c1 -t1"
score="1"/>
        </quorumd>


Customers may wish to put the quorum on an lvm device (in case they have a
failing disk on the cluster node).  This works, but using the
/dev/mapper/qvg-qlv does not work.

Version-Release number of selected component (if applicable):
 
device-mapper-multipath-0.4.7-8.el5
cman-2.0.60-1.el5

How reproducible:

Every time
Steps to Reproduce:
1. Configure cluster
2. Add qdisk to point to /dev/mapper/Name
3. start cman , start qdisk, note qdisk votes dont count or show in cman_tool nodes.
  
Actual results:

Spend some time finding out the various options that work, and wont work.

Expected results:

devices created by device-mapper to work.

Additional information:

Tested on 5.1 beta, same results.
Comment 2 Lon Hohberger 2007-09-18 10:51:54 EDT
Ok - I think this is related to a CMAN limitation where the device can't be
greater than 16 characters wide.
Comment 3 Lon Hohberger 2007-09-18 10:52:26 EDT
Fortuitously, I have a patch to fix the limitation.
Comment 4 Lon Hohberger 2007-09-18 10:57:22 EDT
Created attachment 198431 [details]
Works around length limitation
Comment 5 Lon Hohberger 2007-09-18 12:20:41 EDT
The correct way to fix this is in cman.
Comment 8 Christine Caulfield 2007-09-19 03:18:11 EDT
Created attachment 199341 [details]
Patch for review

The patch is trivial, libcman was checking the quorum device name against the
maximum cluster name length rather than the maximum cluster member name length.
The latter is 255 characters, the former 15!
Comment 10 Kiersten (Kerri) Anderson 2007-09-19 14:06:23 EDT
Devel ACK for 5.1
Comment 11 Chris Feist 2007-09-19 15:20:53 EDT
Committed to RHEL51 (and built in cman-2.0.73-1)
Comment 14 Christine Caulfield 2007-09-25 02:59:42 EDT
*** Bug 275821 has been marked as a duplicate of this bug. ***
Comment 19 errata-xmlrpc 2007-11-07 11:59:54 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0575.html

Note You need to log in before you can comment on or make changes to this bug.