Bug 27618 - [bind-utils 9.1.0] "dig @fqhn" SIGSEGV - core dumped
[bind-utils 9.1.0] "dig @fqhn" SIGSEGV - core dumped
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
: 28150 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-14 09:43 EST by Thorsten Schroeder
Modified: 2016-11-24 10:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-14 09:43:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Schroeder 2001-02-14 09:43:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [de] (X11; U; Linux 2.4.0-0.99.11error1 i686)


After update 7.0 -> 7.0.90 (fisher) dig crashes and dumps core when using a
fqhn as @nameserver. That down't happen if you use the IP-address instead
of the nameservers FQHN. Example: dig @ns1.so36.net www.so36.net crashes,
dig @212.84.245.4 www.so36.net not.

Reproducible: Always
Steps to Reproduce:
1. dig @fqhn any.host

	

Actual Results:  core dumped (SIGSEGV)
Program terminated with signal 11, Segmentation fault.

Expected Results:  nameserver query about a host

[ths@error ths]$ gdb dig core
GNU gdb 5.0
Copyright 2000 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...(no debugging symbols
found)...
Core was generated by `dig @ns1.so36.net www.so36.net'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/lib/libdns.so.3...(no debugging symbols
found)...done.
Loaded symbols for /usr/lib/libdns.so.3
Reading symbols from /lib/libnsl.so.1...done.
Loaded symbols for /lib/libnsl.so.1
Reading symbols from /lib/libpthread.so.0...done.

warning: Unable to set global thread event mask: generic error
[New Thread 1024 (LWP 1374)]
Error while reading shared library symbols:
Can't attach LWP 1374: No such process
Reading symbols from /usr/lib/libisc.so.3...done.
Loaded symbols for /usr/lib/libisc.so.3
Reading symbols from /lib/libc.so.6...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
#0  0x402e40ee in __select () from /lib/libc.so.6
(gdb)
Comment 1 Bernhard Rosenkraenzer 2001-02-14 13:09:28 EST
Update your glibc.
Comment 2 Bernhard Rosenkraenzer 2001-02-17 12:52:48 EST
*** Bug 28150 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.