Bug 28150 - dig segfaults on execution
Summary: dig segfaults on execution
Status: CLOSED DUPLICATE of bug 27618
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-17 17:27 UTC by David Lawrence
Modified: 2016-11-24 14:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-17 17:27:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Tattersall 2001-02-17 17:27:16 UTC
the command line:
dig @netpath.net mebtel.net any
results in:
Segmentation fault

AN strace of the command shows (the last few lines only)
open("/home/devel/dlt/.digrc", O_RDONLY) = -1 ENOENT (No such file or
directory)
open("/etc/resolv.conf", O_RDONLY)      = 7
fstat64(7, {st_mode=S_IFREG|0644, st_size=87, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40
017000
read(7, "search devel.redhat.com redhat.c"..., 4096) = 87
read(7, "", 4096)                       = 0
close(7)                                = 0
munmap(0x40017000, 4096)                = 0
kill(7848, SIGRT_0)                     = 0
rt_sigaction(SIGHUP, {0x401845a0, ~[], 0x4000000}, NULL, 8) = 0
rt_sigsuspend([] <unfinished ...>
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

Comment 1 Bernhard Rosenkraenzer 2001-02-17 17:52:52 UTC
Please check whether a bug has already been reported before entering a new bug
report.

*** This bug has been marked as a duplicate of 27618 ***


Note You need to log in before you can comment on or make changes to this bug.