Bug 277031 - NetwrokManager crash updating wireless network list after hibernate
NetwrokManager crash updating wireless network list after hibernate
Status: CLOSED DUPLICATE of bug 281071
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 15:04 EDT by Carlos "casep" Sepulveda
Modified: 2008-02-11 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 22:41:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos "casep" Sepulveda 2007-09-04 15:04:09 EDT
Description of problem:

NetworkManager crash updating wireless network list.

Version-Release number of selected component (if applicable):

NetworkManager-0.6.5-7.fc7

How reproducible:

Almost every time.
After a while I can restart the service, perhaps a malformed wireless network.


Steps to Reproduce:
1. hibernate.
2. de-hibernate.
3. NetworkManager will crash, even if You restart the service.
  
Actual results:

NetworkManager crash.

Expected results:

NetworkManager present updated wireless network list.

Additional info:

Sep  4 13:59:26 t41 NetworkManager: <info>  starting... 
Sep  4 13:59:26 t41 NetworkManager: <info>  eth1: Device is fully-supported
using driver 'ipw2100'. 
Sep  4 13:59:26 t41 NetworkManager: <info>  nm_device_init(): waiting for
device's worker thread to start 
Sep  4 13:59:26 t41 NetworkManager: <info>  nm_device_init(): device's worker
thread started, continuing. 
Sep  4 13:59:26 t41 NetworkManager: <info>  Now managing wireless (802.11)
device 'eth1'. 
Sep  4 13:59:26 t41 NetworkManager: <info>  Deactivating device eth1. 
Sep  4 13:59:26 t41 NetworkManager: <info>  eth0: Device is fully-supported
using driver 'e1000'. 
Sep  4 13:59:26 t41 NetworkManager: <info>  nm_device_init(): waiting for
device's worker thread to start 
Sep  4 13:59:26 t41 NetworkManager: <info>  nm_device_init(): device's worker
thread started, continuing. 
Sep  4 13:59:26 t41 NetworkManager: <info>  Now managing wired Ethernet (802.3)
device 'eth0'. 
Sep  4 13:59:26 t41 NetworkManager: <info>  Deactivating device eth0. 
Sep  4 13:59:26 t41 NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device eth0 link now 0 
Sep  4 13:59:26 t41 NetworkManager: <info>  nm-device-802-3-ethernet.c -
nm_device_802_3_ethernet_link_deactivated (149) device eth0 scheduled
link_deactivated_helper 
Sep  4 13:59:26 t41 NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device eth1 link now 0 
Sep  4 13:59:26 t41 NetworkManager: <info>  Updating allowed wireless network
lists. 
Sep  4 13:59:26 t41 NetworkManager: <info>  nm-device-802-3-ethernet.c -
link_deactivated_helper (129) device eth0 will set active link to FALSE 
Sep  4 13:59:36 t41 NetworkManager: <WARN>  nm_hal_deinit(): libhal shutdown
failed - Connection is closed 
Sep  4 13:59:36 t41 NetworkManager: <info>  SWITCH: no current connection, found
better connection 'eth1'. 
Sep  4 13:59:36 t41 NetworkManager: <WARN>  nm_signal_handler(): Caught signal
6.  Generating backtrace... 
Sep  4 13:59:36 t41 NetworkManager: ******************* START
**********************************
Sep  4 13:59:36 t41 NetworkManager: <info>  Successfully reconnected to the
system bus. 
Sep  4 13:59:36 t41 NetworkManager: (no debugging symbols found)
Sep  4 13:59:36 t41 NetworkManager: Using host libthread_db library
"/lib/libthread_db.so.1".
Sep  4 13:59:36 t41 NetworkManager: (no debugging symbols found)
Sep  4 13:59:37 t41 last message repeated 12 times
Sep  4 13:59:37 t41 NetworkManager: [Thread debugging using libthread_db enabled]
Sep  4 13:59:37 t41 NetworkManager: [New Thread -1208482112 (LWP 5297)]
Sep  4 13:59:37 t41 NetworkManager: [New Thread -1218974832 (LWP 5303)]
Sep  4 13:59:37 t41 NetworkManager: [New Thread -1208484976 (LWP 5300)]
Sep  4 13:59:37 t41 NetworkManager: (no debugging symbols found)
Sep  4 13:59:37 t41 last message repeated 5 times
Sep  4 13:59:37 t41 NetworkManager: 0x00110402 in __kernel_vsyscall ()
Sep  4 13:59:37 t41 NetworkManager: #0  0x00110402 in __kernel_vsyscall ()
Sep  4 13:59:37 t41 NetworkManager: #1  0x00425d3b in waitpid () from
/lib/libpthread.so.0
Sep  4 13:59:37 t41 NetworkManager: #2  0x0806d350 in ?? ()
Sep  4 13:59:37 t41 NetworkManager: #3  0x0806d441 in ?? ()
Sep  4 13:59:37 t41 NetworkManager: #4  <signal handler called>
Sep  4 13:59:37 t41 NetworkManager: #5  0x00110402 in __kernel_vsyscall ()
Sep  4 13:59:37 t41 NetworkManager: #6  0x00181fa0 in raise () from /lib/libc.so.6
Sep  4 13:59:37 t41 NetworkManager: #7  0x001838b1 in abort () from /lib/libc.so.6
Sep  4 13:59:37 t41 NetworkManager: #8  0x00db5f75 in ?? () from /lib/libdbus-1.so.3
Sep  4 13:59:37 t41 NetworkManager: #9  0x00db1ef6 in ?? () from /lib/libdbus-1.so.3
Sep  4 13:59:37 t41 NetworkManager: #10 0x00d9b6f8 in
dbus_connection_send_with_reply_and_block ()
Sep  4 13:59:37 t41 NetworkManager:    from /lib/libdbus-1.so.3
Sep  4 13:59:37 t41 NetworkManager: #11 0x0807c2ba in
nm_dhcp_manager_get_state_for_device ()
Sep  4 13:59:37 t41 NetworkManager: #12 0x0806eea1 in nm_act_request_new ()
Sep  4 13:59:37 t41 NetworkManager: #13 0x0806a683 in ?? ()
Sep  4 13:59:37 t41 NetworkManager: #14 0x004dda91 in ?? () from
/lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: #15 0x004df7f2 in g_main_context_dispatch ()
from /lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: #16 0x004e27cf in ?? () from
/lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: #17 0x004e2b79 in g_main_loop_run () from
/lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: #18 0x08069348 in main ()
Sep  4 13:59:37 t41 NetworkManager: 
Sep  4 13:59:37 t41 NetworkManager: Thread 3 (Thread -1208484976 (LWP 5300)):
Sep  4 13:59:37 t41 NetworkManager: #0  0x00110402 in __kernel_vsyscall ()
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #1  0x0021fa43 in poll () from /lib/libc.so.6
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #2  0x004e2803 in ?? () from
/lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #3  0x004e2b79 in g_main_loop_run () from
/lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #4  0x080568de in ?? ()
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #5  0x004fd66f in ?? () from
/lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #6  0x0041e44b in start_thread () from
/lib/libpthread.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #7  0x0022980e in clone () from /lib/libc.so.6
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: 
Sep  4 13:59:37 t41 NetworkManager: Thread 2 (Thread -1218974832 (LWP 5303)):
Sep  4 13:59:37 t41 NetworkManager: #0  0x00110402 in __kernel_vsyscall ()
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #1  0x0021fa43 in poll () from /lib/libc.so.6
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #2  0x004e2803 in ?? () from
/lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #3  0x004e2b79 in g_main_loop_run () from
/lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #4  0x080568de in ?? ()
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #5  0x004fd66f in ?? () from
/lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #6  0x0041e44b in start_thread () from
/lib/libpthread.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #7  0x0022980e in clone () from /lib/libc.so.6
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: 
Sep  4 13:59:37 t41 NetworkManager: Thread 1 (Thread -1208482112 (LWP 5297)):
Sep  4 13:59:37 t41 NetworkManager: #0  0x00110402 in __kernel_vsyscall ()
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #1  0x00425d3b in waitpid () from
/lib/libpthread.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #2  0x0806d350 in ?? ()
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #3  0x0806d441 in ?? ()
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #4  <signal handler called>
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #5  0x00110402 in __kernel_vsyscall ()
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #6  0x00181fa0 in raise () from /lib/libc.so.6
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #7  0x001838b1 in abort () from /lib/libc.so.6
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #8  0x00db5f75 in ?? () from /lib/libdbus-1.so.3
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #9  0x00db1ef6 in ?? () from /lib/libdbus-1.so.3
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #10 0x00d9b6f8 in
dbus_connection_send_with_reply_and_block ()
Sep  4 13:59:37 t41 NetworkManager:    from /lib/libdbus-1.so.3
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #11 0x0807c2ba in
nm_dhcp_manager_get_state_for_device ()
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #12 0x0806eea1 in nm_act_request_new ()
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #13 0x0806a683 in ?? ()
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #14 0x004dda91 in ?? () from
/lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #15 0x004df7f2 in g_main_context_dispatch ()
from /lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #16 0x004e27cf in ?? () from
/lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #17 0x004e2b79 in g_main_loop_run () from
/lib/libglib-2.0.so.0
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #18 0x08069348 in main ()
Sep  4 13:59:37 t41 NetworkManager: No symbol table info available.
Sep  4 13:59:37 t41 NetworkManager: #0  0x00110402 in __kernel_vsyscall ()
Sep  4 13:59:37 t41 NetworkManager: The program is running.  Quit anyway (and
detach it)? (y or n) [answered Y; input not from terminal]
Sep  4 13:59:37 t41 NetworkManager: ******************* END
**********************************
Comment 1 Dan Williams 2008-02-11 22:41:58 EST
Probably an SSID that NM wasn't handling correctly...

*** This bug has been marked as a duplicate of 281071 ***

Note You need to log in before you can comment on or make changes to this bug.