Bug 281071 - nm_applet dies when it encounters an SSID containing a "/"
nm_applet dies when it encounters an SSID containing a "/"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 277031 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-06 13:48 EDT by Matthew Miller
Modified: 2008-04-10 16:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.6.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 16:44:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback from crashing nm-applet (2.78 KB, text/plain)
2007-09-06 13:48 EDT, Matthew Miller
no flags Details

  None (edit)
Description Matthew Miller 2007-09-06 13:48:17 EDT
Description of problem:

If NetworkManager encounters an SSID that is in the form of a URL, like
"http://example.org/" or "http://mattdm.org/", nm-applet crashes immediately.
(Just being exposed to it "in the air" is enough.)

In older versions, the main NetworkManager process also died, but recently it
seems to keep running. However, I'm not sure it's not corrupted -- in order to
restart nm-applet, I must first restart NetworkManagerDispatcher.


Version-Release number of selected component (if applicable):

  NetworkManager 0.6.5-9.fc8
  kernel 2.6.23-0.164.rc5.fc8,
  wpa_supplicant 0.5.7-7 (relevant? network is unencrypted.)


How reproducible:

  100% Every Time, Guaranteed.

Steps to Reproduce:
1. Come to my house.
2. Turn on your laptop with wireless antenna off.
3. Look, there's the applet happily running but seeing no networks.
4. Move to a part of the house where you can only see the neighbor's net.
5. Turn on the antenna.
6. There's the neighbor's SSID. And maybe another neighbor too.
7. Move back into range of my access point.
  
Actual results:

  Blam.

Expected results:

  My SSID shows up in the little drop-down list; everything works.

Additional info:

  Using orinoco_pci, if that matters.
Comment 1 Matthew Miller 2007-09-06 13:48:17 EDT
Created attachment 189031 [details]
traceback from crashing nm-applet
Comment 2 Matthew Miller 2007-09-06 13:53:43 EDT
Perhaps related:

http://bugzilla.gnome.org/show_bug.cgi?id=436553
Comment 3 Matthew Miller 2007-09-07 08:52:34 EDT
I narrowed it down -- it's the forward-slash character, "/", that's causing the
problem. And, duh, in retrospect, this is obvious from the dbus error message
which complains about

/org/freedesktop/NetworkManager/Devices/wlan0/Networks/http_3a_//mattdm_2e_org/wifi

Comment 4 Dan Williams 2008-02-11 22:39:25 EST
Fixed upstream; should filter back to FC7 with the 0.6.6 update when that lands.
Comment 5 Dan Williams 2008-02-11 22:41:59 EST
*** Bug 277031 has been marked as a duplicate of this bug. ***
Comment 6 Dan Williams 2008-04-10 16:44:45 EDT
0.6.6 has been pushed as an F7 update.

Note You need to log in before you can comment on or make changes to this bug.