Bug 27755 - no EOF after print jobs to HP deskjet 890C
no EOF after print jobs to HP deskjet 890C
Status: CLOSED DUPLICATE of bug 25445
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-15 02:58 EST by Jay Berkenbilt
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-16 06:00:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Berkenbilt 2001-02-15 02:58:55 EST
In previous versions of RedHat, the print setup tools let you select things
like "send EOF after print job", "fix stair-stepping text", and "fast
text".  These were useful for enabling straight text to be sent to the
printer and having the Right Thing happen.

Right now, if I use printconf to configure my printer and tell it I have an
HP Deskjet 890c, I can print postscript to it, but if I print text, the
green light flashes on the printer because it is waiting for an explicit
EOF.

A quick perusal of the new print configuration stuff seems to suggest that
it is supposed to know about this stuff automatically, but it doesn't seem
to.  In previous versions of RedHat, I've always set up three printers: one
with the deskjet driver which prints very fast and with relatively low
quality to the 890c, one with the cdj550 driver which is medium, and one
with the cdj850 driver which takes advantage of the full capability of the
printer and is very slow.  By selecting all the above checkboxes, I could
get text and postscript printing with varying qualities and speeds.

I have not figured out anyway to do this under the new system, at least not
via the graphical configuration tool (which, by the way, doesn't seem to be
accessible from the default gnome desktop menu which I don't use anyway but
checked before generating this bug report!).  I haven't studied the
underlying configuration files too much partly because of the very scant
documentation.

Is this system expected to mature before the real 7.1?  What level of
printing functionality is expected?  Is there a bug here or am I just
missing something?
Comment 1 Glen Foster 2001-02-15 20:11:46 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Crutcher Dunnavant 2001-02-19 23:59:57 EST

*** This bug has been marked as a duplicate of 25445 ***

Note You need to log in before you can comment on or make changes to this bug.