Bug 25445 - mfomatic doesn't send EOF at end of Postscript Jobs.
mfomatic doesn't send EOF at end of Postscript Jobs.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
All Linux
high Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
Florence Gold
:
: 26471 27755 27813 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-31 22:53 EST by Jack Howarth
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-28 22:42:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jack Howarth 2001-01-31 22:53:04 EST
While I discovered this using the srpms from fisher on linuxppc,
I suspect the same is true on the other platforms as well. It
appears that there is no equivalent to the 'send EOF to eject
page at end of print job' option in printconf as there was in
printtool. The net result is that the page is not ejected at the
end of a printjob. This occurs with the Epson 740 print drivers.
I noticed a comment in the magic filters for the 760 drivers
suggesting that the author had been able to figure out how to make
this sending if the EOF work. This problem definitely has to be
resolved if Redhat intends to move over to these magicfilters.
Comment 1 Glen Foster 2001-02-01 15:01:18 EST
We (Red Hat) should really try to fix this before the next release.
Comment 2 Crutcher Dunnavant 2001-02-03 14:55:24 EST
Okay, the 'correct' way to send Postscript to a printer is to perform the LF ->
CRLF translation, AND to send EOF at the end of the job. Many Postscript
printers are smart enough to do this themselves. magicfilter does this, but the
ghostscript wrapper we are using, mfomatic, does not.

I will make it do this.
Comment 3 Crutcher Dunnavant 2001-02-03 17:02:40 EST
Hmm, this is tricker than I thought.
Because of the nature of the foomatic system, it is difficult to tell if I am
sending Postscript output after it passes through mfomatic. I could
unconditionally stick an EOF on everything I send, but I don't know if this
breaks PCL, PJL, PPA, etc. printers.

Add to this the nature of the piping system in mfomatic, and this gets rather
complex. Hmm.
Comment 4 Crutcher Dunnavant 2001-02-08 11:44:38 EST
*** Bug 26471 has been marked as a duplicate of this bug. ***
Comment 5 Tim Waugh 2001-02-08 11:47:25 EST
Yes, it needs to be an option, like in printtool.  One setting doesn't work for
everyone. :-(
Comment 6 Crutcher Dunnavant 2001-02-08 11:51:56 EST
Yes, one setting /does/ work for everyone.
It is safe to always send that EOF at the end of Postscript jobs.
I'm working with Grant Taylor to figgure out how.
Comment 7 Tim Waugh 2001-02-14 08:02:39 EST
Crutcher, we need an option for this.  Sending EOF at the end of a PS job isn't
going to help my text print job, is it?
Comment 8 Crutcher Dunnavant 2001-02-19 23:59:53 EST
*** Bug 27755 has been marked as a duplicate of this bug. ***
Comment 9 Crutcher Dunnavant 2001-02-21 22:15:58 EST
*** Bug 27813 has been marked as a duplicate of this bug. ***
Comment 10 Jay Berkenbilt 2001-02-24 01:27:05 EST
In Wolverine, printing PostScript files to my HP Deskjet 890C using the deskjet,
cdj550, or cdj890 drivers works fine.  Printing text is another story.  I'll
create a new bug.
Comment 11 Crutcher Dunnavant 2001-02-28 07:46:20 EST
Hmmm, Okay.
PostScript jobs want a terminating EOT (octal 004)
Text jobs want a terminating FF (octal 014)

I'm going to try hard to shoehorn these into the general case, because otherwise
I have to extend the config front end to allow for non-generated options, which
would be useful, but isn't currently supported.

Will finnish after some sleep.
Comment 12 Crutcher Dunnavant 2001-02-28 22:42:54 EST
Text jobs now get their terminating '\014' form feed.
Working on '\004' end of transmission for postscript.
Comment 13 Crutcher Dunnavant 2001-03-02 12:36:27 EST
fixed.
ick

Note You need to log in before you can comment on or make changes to this bug.