This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 277581 - qmake-qt4.64bit not finding binary
qmake-qt4.64bit not finding binary
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt4 (Show other bugs)
7
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 19:39 EDT by Ben Boeckel
Modified: 2008-05-13 03:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 12:33:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Boeckel 2007-09-04 19:39:43 EDT
Description of problem:
When qmake-qt4 is invoked, i get the following error with qt4-devel.x86_64
installed and not the 32bit version.
/usr/bin/qmake-qt4: line 14: /usr/lib/qt4/bin/qmake-qt4: No such file or directory
/usr/bin/qmake-qt4: line 14: exec: /usr/lib/qt4/bin/qmake-qt4: cannot execute:
No such file or directory

It worked earlier, but after updating (I hadn't updated in a while, so I can't
be sure which update it started in exactly)

Version-Release number of selected component (if applicable):
# rpm -q qt4-devel
qt4-devel-4.3.1-3.fc7

How reproducible:
N/A

Steps to Reproduce:
1. Install qt4-devel (64bit)
2. Try qmake-qt4
  
Actual results:
Actual binary isn't found

Expected results:
Creation of Makefile from a .pro file

Additional info:
Comment 1 Kevin Kofler 2007-09-14 12:47:06 EDT
I spoke with the reporter on IRC: the problem is this: the wrapper script 
queries %{_libdir} from RPM: /bin/rpm --eval "%{_libdir}/qt4" 2>/dev/null

However, this only works with redhat-rpm-config installed, and there doesn't 
seem to be anything requiring it. Installing redhat-rpm-config "fixes" this 
bug.
Comment 2 Rex Dieter 2007-09-14 13:09:41 EDT
OK, it already has Requires: rpm, just make it redhat-rpm-config :)
unless we can come up with some other better way of handling multilib'ness in 
the app wrapper.  I chose rpm approach in the first place over pkg-config, 
since it respects setarch (ie, on x86_64, 'setarch i386 qmake' does the right 
thing).
Comment 3 Rex Dieter 2007-09-14 13:57:12 EDT
%changelog
* Fri Sep 14 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-8
- -x11: Req: redhat-rpm-config rpm, app-wrapper/multilib fun (#277581)
Comment 4 Rex Dieter 2008-04-04 14:15:12 EDT
fwiw, we'll be using %%_bindir as %%_qt4_bindir in qt-4.4.0, so that should
alleviate any need for hacks.
Comment 5 Kevin Kofler 2008-05-13 03:33:35 EDT
But we have to find a solution for bug 446167 before we can do that. :-(

Note You need to log in before you can comment on or make changes to this bug.