Bug 27789 - GUI unresponsiveness during data transfer
Summary: GUI unresponsiveness during data transfer
Status: CLOSED DUPLICATE of bug 24335
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-15 12:47 UTC by Emmanuel Galanos
Modified: 2015-01-07 23:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 01:35:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Emmanuel Galanos 2001-02-15 12:47:36 UTC
When up2date is run under X it first displays the splash screen
After clicking on next button, the update agent connects to redhat and
everything works as it is meant to
However I am on a 28.8k modem connection and I have a full install
It takes over 90 seconds for the up2date process to check what packages I need
This is not bad per se, but the fact that during this 90+ seconds the GUI
does not handle expose events, thus giving the appearance of it having
crashed Not good for a GUI application.
Some IO multiplexing or a seperate worker thread would be in order for this
application.

Comment 1 Cristian Gafton 2001-02-20 01:35:00 UTC
Assigned QA to jturner

Comment 2 Preston Brown 2001-02-20 18:16:47 UTC

*** This bug has been marked as a duplicate of 24335 ***


Note You need to log in before you can comment on or make changes to this bug.