Bug 27789 - GUI unresponsiveness during data transfer
GUI unresponsiveness during data transfer
Status: CLOSED DUPLICATE of bug 24335
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2001-02-15 07:47 EST by Emmanuel Galanos
Modified: 2015-01-07 18:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-19 20:35:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Emmanuel Galanos 2001-02-15 07:47:36 EST
When up2date is run under X it first displays the splash screen
After clicking on next button, the update agent connects to redhat and
everything works as it is meant to
However I am on a 28.8k modem connection and I have a full install
It takes over 90 seconds for the up2date process to check what packages I need
This is not bad per se, but the fact that during this 90+ seconds the GUI
does not handle expose events, thus giving the appearance of it having
crashed Not good for a GUI application.
Some IO multiplexing or a seperate worker thread would be in order for this
Comment 1 Cristian Gafton 2001-02-19 20:35:00 EST
Assigned QA to jturner
Comment 2 Preston Brown 2001-02-20 13:16:47 EST

*** This bug has been marked as a duplicate of 24335 ***

Note You need to log in before you can comment on or make changes to this bug.