Bug 279691 - Yum does no scan for updates across all available archs
Yum does no scan for updates across all available archs
Status: CLOSED DUPLICATE of bug 315541
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 18:52 EDT by Deepak Bhole
Modified: 2009-03-24 17:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 17:14:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Deepak Bhole 2007-09-05 18:52:00 EDT
Description of problem:

When one does a yum update on a specific package ABC, yum searches for updates
for packages (say XYZ) that require the installed ABC version-release. It is
expected that yum would do a search for XYZ updates for all available archs, but
it does not.

Version-Release number of selected component (if applicable):
3.0.1-5.el5

How reproducible:
Always

Steps to Reproduce:
To reproduce on a 64-bit installation of RHEL5:

1. Install an older version (than the one in rhn) of postgresql (only 64- bit
available) and postgresql-devel (32- and 64- bit). The RHEL5 base DVD has older
versions of these.
2. Subscribe to rhn and run 'yum update postgresql'
  
Actual results:
Yum exits with an error:

Error: Unable to satisfy dependencies
Error: Package postgresql-devel needs postgresql = 8.1.4-1.1, this is not available.

The reason for the above error is that the yum update command causes yum to pack
only postgresql and postgresql-devel (64-bit) in the transaction set. This
leaves the 32-bit postgresql-devel, which needs an older version of postgresql,
still on the system.

Expected results:
Upgrade should succeed, with the new upgrade bringing in the new postgresql and
the new 32- and 64- bit postgresql-devel packages
Comment 1 Subhendu Ghosh 2009-03-24 17:14:03 EDT

*** This bug has been marked as a duplicate of bug 315541 ***

Note You need to log in before you can comment on or make changes to this bug.