This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 315541 - Multilibness not taken into account when resolving dependencies
Multilibness not taken into account when resolving dependencies
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: James Antill
:
: 279691 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-02 12:01 EDT by Radek Bíba
Modified: 2009-03-25 02:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 02:21:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output from yum update lvm2 (2.47 KB, text/plain)
2007-10-02 12:01 EDT, Radek Bíba
no flags Details

  None (edit)
Description Radek Bíba 2007-10-02 12:01:38 EDT
Description of problem:
This problem revealed when QE was testing availability and updateability of
lvm2 from RHN. The new lvm2 requires a newer device-mapper, but yum pulled
down only the native version. Transaction test then failed because the old
compat-arch package was still installed, which created a conflict. It happened
on all multilib arches (i386 passed), attached is a log from an x86_64 box.

Version-Release number of selected component (if applicable):
yum-3.0.1-5.el5

How reproducible:
Always

Steps to Reproduce:
See the attachment for inspiration.
  
Actual results:
Transaction test failure, yum exits.

Expected results:
Yum should pull down both rpms (for both arches), the transaction would pass.

Additional info:
Good thing 'yum update' is able to update both device-mapper packages, so this
is nothing that would block full upgrade.
Comment 1 Radek Bíba 2007-10-02 12:01:38 EDT
Created attachment 213631 [details]
Output from yum update lvm2
Comment 2 Subhendu Ghosh 2009-03-24 17:14:03 EDT
*** Bug 279691 has been marked as a duplicate of this bug. ***
Comment 3 James Antill 2009-03-25 02:21:12 EDT
yum has got better since 3.0.1 ... so closing this, although it's still not as prefect.

Note You need to log in before you can comment on or make changes to this bug.