Bug 28147 - Signal 9 during format
Signal 9 during format
Status: CLOSED DUPLICATE of bug 19523
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-17 11:22 EST by Willem Jacobusse
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 04:04:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Ananconda dump (816 bytes, text/plain)
2001-02-17 11:23 EST, Willem Jacobusse
no flags Details

  None (edit)
Description Willem Jacobusse 2001-02-17 11:22:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)


During install on an existing fat32 partition, whilst formatting the 
filesystem the installer crashes and returns the signal 9 error message. I 
downloaded the anaconda update 20001009.img with the same result.

Reproducible: Always
Steps to Reproduce:
1.Normal workstation install, either from cdrom, diskette or harddisk
2.Install on existing fat32 (w98se) partition, without any linux partitions
3.creating loopback filesystem
4. crash occurs during formatting filesystem	

Dump:Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
  File "/tmp/updates/todo.py", line 1485, in doInstall
    self.fstab.makeFilesystems ()
  File "/tmp/updates/fstab.py", line 666, in makeFilesystems
    isys.umount("/mnt/loophost")
  File "/usr/lib/anaconda/isys.py", line 116, in umount
    mountCount[what] = mountCount - 1
TypeError: bad operand type(s) for -

Local variables in innermost frame:
what: /mnt/loophost
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I0
sS'fnames'
p9
(dp10

<failed>
Comment 1 Willem Jacobusse 2001-02-17 11:23:34 EST
Created attachment 10300 [details]
Ananconda dump
Comment 2 Willem Jacobusse 2001-02-19 04:04:35 EST
Problem only occurs when installing on a fat partiton. No problem at all when 
installing on a Linux partition.
Comment 3 Michael Fulbright 2001-02-20 14:38:36 EST

*** This bug has been marked as a duplicate of 19523 ***

Note You need to log in before you can comment on or make changes to this bug.