Bug 2818 - Session crashing after 10-15 mins of usage.
Session crashing after 10-15 mins of usage.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: basesystem (Show other bugs)
6.0
sparc Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
: 2294 2315 2399 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-14 05:43 EDT by prasingh
Modified: 2008-05-01 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-02 05:48:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description prasingh 1999-05-14 05:43:59 EDT
After Logging in to the workstation Sparc-20, my session
crashes after about 10-15 minutes of usage and it brings
me back to the console login prompt. Also, I see that
after the session crash, if I try to relogin, it just
sits there doing some processing and doesn't let me in.
I then have to telnet into the machine from another host
and shutdown the machine. I also get a core dump with the
crash and twice, I have tried to debug the file and it seems
to be associated with the 'ed' process. However, I have not
been using 'ed' ever. I guess its some system process trying
to use 'ed' to write a certain log and it causes a crash.
Let me know if you want me to send you the core file for
debugging.

Thanks
Pradeep Singh
Comment 1 Jeff Johnson 1999-05-14 15:46:59 EDT
This is a known problem. There will be errata items for sparc
in the next week or so. The problem is in EGCS that mis-compiles
the kernel that causes X to crash.  I don't have any further info at
this time.
Comment 2 Jeff Johnson 1999-05-16 20:22:59 EDT
*** Bug 2315 has been marked as a duplicate of this bug. ***

navigator crashes on sparc (axil 311 running 2.2.5-smp) two
processor system, with X exported to a DEC UDB via ethernet.
The most common lockup shows just the outline of the
navigator screen with no buttons and the display area all
white.  Generally have to kill netscape, as the corner
buttons don't work.

When accessing the NY Times site, or yahoo or altavista, it
would die with a bus error.*** Bug 2399 has been marked as a duplicate of this bug. ***

Sparc locks up during period of inactivity.  The box
responds to ping, but one cannot telnet/rlogin.  X is
exported to a companion UDB, which has a nmessage that
XDM is not receiving from the sparc.

The most recent lock up had the following messages in the
log:
Apr 28 03:02:19 fritz pumpd[198]: renewed lease for
interface eth0
Apr 28 05:59:45 fritz kernel: Kernel panic: skput:over:
f00b1fbc:1448 put:1448
dev:eth0
Apr 28 08:50:10 fritz syslogd 1.3-3: restart.

The first lockup showed nothing in the log.

The only way out of this is to power cycle the machine.
Comment 3 Jeff Johnson 1999-05-16 20:23:59 EDT
*** Bug 2294 has been marked as a duplicate of this bug. ***

Apr 19 14:11:49 cinder kernel: ARCH: SUN4M
Apr 19 14:11:49 cinder kernel: TYPE: Sun4m SparcStation10/20

Apr 19 14:11:49 cinder kernel: fb0: cgsix at e.00000000 TEC
Rev 4 CPU sparc Rev b

I just installed rawhide, and it works fine for a while, but
sometimes X and gdm crash for no apparent reason. Haven't
been able to collect any error messages so far.
Comment 4 Eugenio Diaz 1999-05-19 09:45:59 EDT
I have been able to reproduce the crash consistently by going into the
Gnome Control Center -> Screen Saver and previewing all savers. After
a while of playing there it consistently crashes the session leaving
the dreaded 'ed' core in the home dir.
Comment 5 Matt Wilson 1999-05-27 17:32:59 EDT
*** Bug 2985 has been marked as a duplicate of this bug. ***

The X server crashes quite often: it seems crashes are
much more frequent where the server is asked to render
some fonts (killer apps are: Netscape, The Gimp, even
xfontsel). The bug shows up also letting the Xserver access
the fonts directly (disabling xfs). I was NOT able to
reproduce the bug 100% of the times, but just a few
minutes of "random" web browsing or rendering some text in
some Type1 fonts with the gimp or xfontsel should be
enough to trigger it. An X session with just xterms runs
for hours without crashes. I've tried the enlightenment WM,
icewm, even a plain-old tvtwm (no panel, no backgrounds,
...) with same results. I've tried opening Netscape from
other hosts (4.51 for Linux/i386, 4.51 for Solaris) with
same results.

------- Additional Comments From jturner@redhat.com  05/24/99 14:45 -------
We are aware of this problem and are working on a fix for it.  Thanks
for the information.
Comment 6 David Miller 1999-06-02 05:48:59 EDT
Fixed with egcs/sparc kernel errata, so this can be closed.

Note You need to log in before you can comment on or make changes to this bug.