Bug 2985 - Red Hat 6.0 sparc (SS5) CG6 X server crashes
Red Hat 6.0 sparc (SS5) CG6 X server crashes
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
sparc Linux
high Severity high
: ---
: ---
Assigned To: Preston Brown
Depends On:
  Show dependency treegraph
Reported: 1999-05-23 12:42 EDT by Marco Colombo
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-08-31 16:51:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Marco Colombo 1999-05-23 12:42:22 EDT
The X server crashes quite often: it seems crashes are
much more frequent where the server is asked to render
some fonts (killer apps are: Netscape, The Gimp, even
xfontsel). The bug shows up also letting the Xserver access
the fonts directly (disabling xfs). I was NOT able to
reproduce the bug 100% of the times, but just a few
minutes of "random" web browsing or rendering some text in
some Type1 fonts with the gimp or xfontsel should be
enough to trigger it. An X session with just xterms runs
for hours without crashes. I've tried the enlightenment WM,
icewm, even a plain-old tvtwm (no panel, no backgrounds,
...) with same results. I've tried opening Netscape from
other hosts (4.51 for Linux/i386, 4.51 for Solaris) with
same results.
Comment 1 Jay Turner 1999-05-24 14:45:59 EDT
We are aware of this problem and are working on a fix for it.  Thanks
for the information.
Comment 2 Matt Wilson 1999-05-27 17:32:59 EDT
*** This bug has been marked as a duplicate of 2818 ***
Comment 3 Marco Colombo 1999-06-01 07:10:59 EDT
Still happens. While it seems to be a little less frequent, it's still
there. Just fire The Gimp, and force it to display some text in
some of the available fonts. Sooner or later it will crash the X
Of course, kernel RPM is kernel-2.2.5-21. The system is a Netra i
(SparcStation 5). I think the FB is a TurboGX, anyway dmesg says:
fb0: cgsix at 0.50000000 TEC Rev 4 CPU sparc Rev b
and it's a 8 bits (256 colors) depth.
There are no messages on X server stderr or syslog. Not all X clients
die, actually I have to kill xterms by hand.
The system itself never crashed.
BTW, the old system was RHL5.1, and worked just fine (for months).
Hope this helps.
Comment 4 David Miller 1999-06-02 05:52:59 EDT
Can you verify that /etc/silo.conf is in fact setup properly
so that it will be booting the new kernel?  Just want to verify

------- Email Received From  Marco Colombo <marco@esi.it> 06/02/99 06:08 -------
Comment 5 Preston Brown 1999-06-02 10:14:59 EDT
Pasted from attached email:

[root@NOC marco]# uname -a
Linux NOC.ESI 2.2.5-21 #1 Sun May 23 15:25:41 EDT 1999 sparc unknown
[root@NOC marco]# cat /proc/version
Linux version 2.2.5-21 (root@bart.devel.redhat.com) (gcc version
egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1 Sun May 23
15:25:41 EDT 1999
Comment 6 Preston Brown 1999-08-31 16:51:59 EDT
running XFree86 3.3.5 (which is about to be released as errata) and
kernel 2.2.5-22, available from the updates site, I was able to
extensively render type1 fonts in gimp without crashing on the same
graphics card you have and a Sparc20.  I hope that 3.3.5 will fix your
problems.  Please get the update when it becomes available (shortly),
and if you continue to have issues, re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.