Bug 283391 - typo in ldap.c
typo in ldap.c
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
7
All Linux
medium Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 283841 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 23:50 EDT by Fran Taylor
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 3.0.5-40.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 23:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes several problems with LDAP support (4.36 KB, patch)
2007-09-10 10:05 EDT, Fran Taylor
no flags Details | Diff

  None (edit)
Description Fran Taylor 2007-09-07 23:50:24 EDT
Description of problem:

There is a typo in the source code file server/ldap.c

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

line 305:
      if ((ldap_method = LDAP_METHOD_DYNAMIC) &&
          (strcmp (search[i], "dhcpHostDN") == 0))
        continue;



Expected results:

line 305:
      if ((ldap_method == LDAP_METHOD_DYNAMIC) &&
          (strcmp (search[i], "dhcpHostDN") == 0))
        continue;


Additional info:

Note that there is only one = sign, there should be two.
Comment 1 Fran Taylor 2007-09-10 10:05:11 EDT
Created attachment 191671 [details]
fixes several problems with LDAP support

this patch fixes several problems - it works well for me
Comment 2 David Cantrell 2007-09-10 10:50:43 EDT
*** Bug 283841 has been marked as a duplicate of this bug. ***
Comment 3 David Cantrell 2007-09-10 10:51:08 EDT
Patch also fixes the problem reported in bug #283841.
Comment 4 Fedora Update System 2007-09-12 12:41:10 EDT
dhcp-3.0.5-40.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2007-09-17 23:21:45 EDT
dhcp-3.0.5-40.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.