Bug 283841 - LDAP service for DHCP doesn't work
Summary: LDAP service for DHCP doesn't work
Status: CLOSED DUPLICATE of bug 283391
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-09 04:57 UTC by Fran Taylor
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 14:50:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fran Taylor 2007-09-09 04:57:01 UTC
Description of problem:

LDAP service for DHCP doesn't work.  This error message is as far as you will get:

invalid dns update type

I will paste clips from the files includes/dhcpd.h and server/stables.c here,
and the problem should be pretty obvious:

includes/dhcpd.h, line 458:
---
# define SV_LDAP_SERVER                 46
# define SV_LDAP_PORT                   47
# define SV_LDAP_USERNAME               48
# define SV_LDAP_PASSWORD               49
# define SV_LDAP_BASE_DN                50
# define SV_LDAP_METHOD                 51
---

server/stables.c, line 487:
---
        { "ldap-server", "t",                           &server_universe, 47 },
        { "ldap-port", "d",                                    
&server_universe, 48 },
        { "ldap-username", "t",                         &server_universe, 49 },
        { "ldap-password", "t",                         &server_universe, 50 },
        { "ldap-base-dn", "t",                          &server_universe, 51 },
        { "ldap-method", "Nldap-methods.",      &server_universe, 52 },
---

Clearly the numbering of the parameters is not the same so things will not line
up.

Comment 1 David Cantrell 2007-09-10 14:50:42 UTC

*** This bug has been marked as a duplicate of 283391 ***


Note You need to log in before you can comment on or make changes to this bug.