Bug 284431 - lesstif-0.95.0-18 causes nedit copy-and-paste to segfault
lesstif-0.95.0-18 causes nedit copy-and-paste to segfault
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lesstif (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 06:32 EDT by A. Lok
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.95.0-20.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 23:23:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes a crash in lesstif-0.95.0-19.fc7 for 32bit x86 (544 bytes, patch)
2007-09-10 14:29 EDT, Edward Sheldrake
no flags Details | Diff

  None (edit)
Description A. Lok 2007-09-10 06:32:59 EDT
Description of problem:
After upgrading lesstif to version 0.95.0-18 (or 19), using copy or paste via
the menu or via the short-cut-keys, causes nedit to segfault.

Version-Release number of selected component (if applicable):
lesstif-0.95.0-17.fc8.i386
nedit-5.5-12.fc8


How reproducible:
-start nedit
-type some text or open a text-file
-select some text
-use ctrl-c or e_dit > c_opy in the menu
-watch the nedit-windows disappear

It seems to have something to do bug #243508 ?
Comment 1 Edward Sheldrake 2007-09-10 14:29:40 EDT
Created attachment 191851 [details]
Fixes a crash in lesstif-0.95.0-19.fc7 for 32bit x86
Comment 2 Edward Sheldrake 2007-09-10 14:31:14 EDT
I can confirm that this problem occurs on Fedora 7 with the lesstif
0.95.0-19.fc7 testing update installed.

I fixed it for myself with the attached patch (fixing a bug/typo in
lesstif-0.95.0-XxxxProperty-64bit.patch).

I don't have any 64bit hardware to test it on.
Comment 3 Patrice Dumas 2007-09-10 17:08:01 EDT
Hans, I let that to you for the moment, I'll look at it
only if you don't.
Comment 4 Hans de Goede 2007-09-16 11:03:12 EDT
Patrice,

Woopsee, my bad. This will indeed go wrong on 32 bit machines due to the missing
{} added by the attached patch. I'm rather busy ATM. Patrice, could you please
do a new release with the attached patch applied?

Thanks,

Hans
Comment 5 Patrice Dumas 2007-09-16 12:27:14 EDT
Yep, I do it now.
Comment 6 Fedora Update System 2007-09-17 23:23:37 EDT
lesstif-0.95.0-20.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.