Bug 28470 - glibc-common fails initial installation
glibc-common fails initial installation
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
: 36635 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-20 12:00 EST by Need Real Name
Modified: 2016-11-24 10:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-22 17:19:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-20 12:00:19 EST
I took a standard Red Hat 7 CD and created a kickstart file and my own comps file so that I could install via NFS mount.  Things worked great until yesterday when I downloaded the new glibc and glibc-common RPMs.

I had some problems with Locale and when checking the file /tmp/install.log on my new installed System, I found the following at the top of it:

Installing glibc-common.
unpacking of archive failed: cpio: Missing hard link
Installing setup.
Installing filesystem.
Installing basesystem.
Installing glibc.                                                         
You have probably fixed this already in the beta, but it appears to me after a quick look that glibc-common should depend on basesystem being installed, as is the case for glibc.
Comment 1 Bill Nottingham 2001-02-20 17:49:11 EST
Which glibc-common package?
Comment 2 Need Real Name 2001-02-20 18:10:11 EST
Sorry, 2.2-12.  I got them from the updates directory for Red Hat 7.
Comment 3 Need Real Name 2001-02-22 13:18:32 EST
I downloaded the source RPM for glibc-2.2-12 from the updates directory.

I modified the spec file so that glibc-common depended on basesystem and rebuilt
the RPM.  Even though glibc-common was installed after basesystem, the same
error occured.
Comment 4 Need Real Name 2001-02-22 17:19:02 EST
I fixed my problem, but I don't think I have found the optimal solution.

In addition to adding a requirement to have basesystem installed, I commented
out the whole section on Hard linking identical locale files together.

This caused the RPM to increase to 8 MB from ~5.5, which is why I don't think it
was optimal.

After the automatic installation of glibc-common failed, I was able to
successfully install it from the command line on tty2 before the end of
installation reboot.  This means it is probably as much an installation problem
as it is a problem with the glibc-common RPM.
Comment 5 Jakub Jelinek 2001-02-23 07:52:58 EST
The bug is in rpm, which does not handle %lang() marked files hardlinked
together between different languages if %_install_langs at install time is not
all. This has been fixed in rawhide (and latest beta release) by not marking
the files with %lang() for the time being.
rpm will be fixed eventually but glibc needs to wait until rpm provides that
as a feature set it can depend on.
Comment 6 Pekka Savola 2001-02-27 04:59:15 EST
I got hit by this too. :-(
Comment 7 LENHOF 2001-04-09 06:09:01 EDT
I have the same problem

Installing glibc-common.
unpacking of archive failed: cpio: Missing hard link

And for now I solved it using a post install after the reboot of my kickstart
installation

NB : In order to avoid some errors on time-zone I rebuilt images of RedHat
installation after making some changes in /usr/lib/anaconda-runtime/upd-instroot
(Changed 2 lines with GLIBC in )


Comment 8 Bill Stephens 2001-04-19 13:22:05 EDT
*** Bug 36635 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.