Bug 285001 - 'intel' driver always detects a TV connected on 965.
'intel' driver always detects a TV connected on 965.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 306921 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-10 15:28 EDT by Jesse Keating
Modified: 2013-01-09 21:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 14:07:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (84.80 KB, text/plain)
2007-09-10 15:28 EDT, Jesse Keating
no flags Details
my Xorg.0.log (76.63 KB, text/plain)
2007-09-14 07:38 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Jesse Keating 2007-09-10 15:28:50 EDT
I have a new Dell XPS M1330 laptop with intel chip.  intel driver is in use.

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated
Graphics Controller (rev 0c)

X log is attached.  Basically it always detects that a TV is plugged in and thus
limits the resolution to something that isn't nice.  If I use xrandr to disable
the TV out my desktop snaps to the right resolution.  This causes things like
rhgb and gdm to be all whacky too.
Comment 1 Jesse Keating 2007-09-10 15:28:50 EDT
Created attachment 191891 [details]
Xorg log file
Comment 2 Matěj Cepl 2007-09-14 07:38:02 EDT
Created attachment 195781 [details]
my Xorg.0.log

I have the same card on my laptop, but I cannot reproduce the problem here:

[matej@viklef ~]$ lspci -n |grep -i 00:02.
00:02.0 0300: 8086:2a02 (rev 0c)
00:02.1 0380: 8086:2a03 (rev 0c)
[matej@viklef ~]$ grep TV /var/log/Xorg.0.log
(II) intel(0): Output TV has no monitor section
(II) intel(0): Output TV disconnected
(II) intel(0): EDID for output TV
(II) intel(0): Output TV disconnected
(II) intel(0):	 Output TV is connected to pipe none
(II) intel(0): Output TV disconnected
(II) intel(0): EDID for output TV
(II) intel(0):	 Output TV is connected to pipe none
(II) intel(0): Output TV disconnected
(II) intel(0): EDID for output TV
[matej@viklef ~]$ 

Although I cannot reproduce the problem with always on TV output, Xorg cannot
detect the size of the monitor as well (don't recognize that it is wide-screen
monitor, when switching manually to 1280x800 it works more or less correctly;
no console, but that's another bug).
Comment 3 Matěj Cepl 2007-09-14 07:39:44 EDT
BTW, this HP Compaq 6710s laptop:

[matej@viklef ~]$ lshal |grep hardware
  system.hardware.product = 'HP Compaq 6710s (GB885EA#AKB)'  (string)
  system.hardware.serial = 'CNU7311QCY'  (string)
  system.hardware.uuid = '7C1127B8-C315-E011-3884-6D990E367929'  (string)
  system.hardware.vendor = 'Hewlett-Packard'  (string)
  system.hardware.version = 'F.08'  (string)
[matej@viklef ~]$ 

Comment 4 Jesse Keating 2007-09-14 09:39:22 EDT
$ lshal |grep hardware
  system.hardware.primary_video.product = 10754  (0x2a02)  (int)
  system.hardware.primary_video.vendor = 32902  (0x8086)  (int)
  system.hardware.product = 'XPS M1330'  (string)
  system.hardware.serial = '6TG3KD1'  (string)
  system.hardware.uuid = '44454C4C-5400-1047-8033-B6C04F4B4431'  (string)
  system.hardware.vendor = 'Dell Inc.'  (string)
  laptop_panel.brightness_in_hardware = false  (bool)

Forgot to include this in the original report.

I have a work around for now, which is to create a dummy monitor with the option
of ignore, and assign "Monitor-TV" to "Dummy" and that keeps X from considering
it when deciding on a resolution.  Now X automatically picks the right
resolution, 1280x800.
Comment 5 Dave Airlie 2007-10-10 20:58:34 EDT
please re-test I updated the quirks in the driver in rawhide from upstream to
cover the Dell XPS 1330 case
Comment 6 Jakub Hrozek 2007-10-12 05:04:17 EDT
(In reply to comment #5)
> please re-test I updated the quirks in the driver in rawhide from upstream 
to
> cover the Dell XPS 1330 case


I've filed a similar bug #306921 - sorry I did not find this one before. It 
seems that Jesse has found the same workaround.

Dave, is the quirk you mentioned only for Dell or will it work with other 
models?
Comment 7 Matěj Cepl 2007-10-12 06:13:52 EDT
*** Bug 306921 has been marked as a duplicate of this bug. ***
Comment 8 Jesse Keating 2007-10-12 14:07:25 EDT
Seems to work well now without my workaround.

Note You need to log in before you can comment on or make changes to this bug.