Bug 306921 - [workaround] TP R61, T61 with Intel 3100 - TV out is on by default, bad resolution selected
[workaround] TP R61, T61 with Intel 3100 - TV out is on by default, bad resol...
Status: CLOSED DUPLICATE of bug 285001
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-26 09:19 EDT by Jakub Hrozek
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-12 06:13:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The original xorg.conf as generated after install (684 bytes, text/plain)
2007-09-26 09:20 EDT, Jakub Hrozek
no flags Details
my working xorg.conf (995 bytes, text/plain)
2007-09-26 09:21 EDT, Jakub Hrozek
no flags Details
An xorg log showing the TV as "connected" (52.35 KB, text/plain)
2007-09-26 09:23 EDT, Jakub Hrozek
no flags Details

  None (edit)
Description Jakub Hrozek 2007-09-26 09:19:20 EDT
Description of problem:
I have a ThinkPad R61 with an Intel X3100 driver. After start, rhgb, gdm and 
de itself are not rendered on the whole screen as 1024x768 resolution is 
selected (native is 1440x960). You can move the mouse pointer over whole 
screen, but panels, windows etc are rendered in upper-left hand corner only.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. grab a thinkpad with a 3100 intel card (R61 and T61 are affected for sure)
2. start system with rhgb or boot into runlevel 5
3. DE/gdm not rendered correctly
Actual results:
wrong resulution selected

Expected results:
the correct resulution selected

Additional info:
There is a workaround proposed by someone of fedoraforum.org. The root cause 
is TV output being on, as one can see with xrandr -q. Disabling the TV output 
with the following lines does the trick for me:

Section "Monitor"
        Identifier   "TVOutput"
        Option       "Disable" "true"

and also adding this to the videocard "Device" section:
Option      "monitor-TV" "TVOutput"
Comment 1 Jakub Hrozek 2007-09-26 09:20:19 EDT
Created attachment 207071 [details]
The original xorg.conf as generated after install
Comment 2 Jakub Hrozek 2007-09-26 09:21:20 EDT
Created attachment 207081 [details]
my working xorg.conf
Comment 3 Jakub Hrozek 2007-09-26 09:23:23 EDT
Created attachment 207101 [details]
An xorg log showing the TV as "connected"
Comment 4 Matěj Cepl 2007-10-12 06:13:52 EDT

*** This bug has been marked as a duplicate of 285001 ***

Note You need to log in before you can comment on or make changes to this bug.