Bug 28510 - sndconfig cannot configure opl3sa2
sndconfig cannot configure opl3sa2
Status: CLOSED DUPLICATE of bug 27509
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-20 17:11 EST by sethbc1980
Modified: 2014-03-16 22:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-22 18:38:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sethbc1980 2001-02-20 17:11:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.23smp i686)


well, i have a gateway solo 2500 and the sound doesn't configure properly. 
it used to on the old redhats, and in other distributions i can load it as
a module seperately

i use the  following command to load the module for other distros (like
slack):

modprobe opl3sa2 io=0x220 mss_io=0x530 mpu_io=0x330 irq=5 dma=0 dma2=1

i used to be able to use sndconfig to set it up but it doesn't work now.  I
have tried modprobing that, even recompiling the kernel with different
options.  It has always been an opl3sa2.


Reproducible: Always
Steps to Reproduce:
1. simply try to configure the opl3sa2 
2. try to use audio



Actual Results:  the gnome sound manager won't work....neither will other
sound configuration devices

Expected Results:  sound should work
Comment 1 Bill Nottingham 2001-02-20 17:13:25 EST
What happens if you add 'isapnp=0' to the end of the options?
Comment 2 sethbc1980 2001-02-20 19:39:52 EST
good call, now, i actually don't even have the io=0x220, its io=0x370(the 
default in sndconfig), i just had to add isapnp=0 to the end of the options for 
opl3sa2 in modules.conf

so here is the line

options opl3sa2 mss_io=0x530 irq=5 dma=0 dma2=1 mpu_io=0x330 io=0x370 isapnp=0

Comment 3 Bill Nottingham 2001-02-20 19:41:32 EST
And that works fine? Good.

Out of curiosity, if you don't have an options line in modules.conf,
and just do 'modprobe opl3sa2 isapnp=1'; does that work?
Comment 4 Glen Foster 2001-02-21 10:13:01 EST
We (Red Hat) should really try to resolve this before next release.
Comment 5 sethbc1980 2001-03-18 02:37:09 EST
well, i'm not sure what i should do, b/c you have released a second beta, and 
it still doesn't work.  heres the deal, it doesn't work in either beta when i 
add the isapnp=1

as far as kernel compatibility--alan has made some changes to the opl3sa2 
module adding information on the isapnp issue.  as far as i could tell, all it 
did was totally break sound support (this was in an ac patch)

in wolverine i have had more trouble with sound, it doesn't add the stuff to 
modules.conf it used to, and so it makes it kind of a pain to get sound to 
run.  but the same still stands true.  isapnp=0 has to be appended to the 
options line (the same as i have above) and isapnp=1 with nothing else says "no 
pnp cards found" or something like that
Comment 6 Trond Eivind Glomsrxd 2001-03-22 18:37:48 EST
Is this a notebook with a Neomagic chipset? This looks a lot like a duplicate of
bug #27509
Comment 7 Trond Eivind Glomsrxd 2001-03-29 15:23:13 EST

*** This bug has been marked as a duplicate of 27509 ***

Note You need to log in before you can comment on or make changes to this bug.