Bug 28520 - rpmdb-redhat doesn't work, wrong db format
Summary: rpmdb-redhat doesn't work, wrong db format
Status: CLOSED DUPLICATE of bug 22911
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-20 23:13 UTC by Daniel Resare
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 23:13:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Resare 2001-02-20 23:13:33 UTC
[noa@localhost rpm]$ rpm -q rpmdb-redhat
rpmdb-redhat-7.0.90-0.20010126

[noa@localhost rpm]$ rpm --redhatprovides foobar
error: cannot open Packages index using db3 - No such file or directory (2)

a strace reveals that rpm seems to ignore the *.rpm files in
/usr/lib/rpmdb/i386-redhat-linux/redhat/ (old format) and instead trying to
open Packages (new format) which isn't there.

open("/usr/lib/rpmdb/i386-redhat-linux/redhat/Packages", O_RDONLY) = -1
ENOENT (No such file or directory)

so the rpmdb-redhat package should be updated to use the new db format
(and a component for the rpmdb-redhat package should be added to bugzilla)

Comment 1 Jeremy Katz 2001-02-21 12:03:26 UTC

*** This bug has been marked as a duplicate of 22911 ***


Note You need to log in before you can comment on or make changes to this bug.