Bug 28526 - XFree86 4.0.2-6 crashes the computer with S3 Savage MX/IX
Summary: XFree86 4.0.2-6 crashes the computer with S3 Savage MX/IX
Status: CLOSED DUPLICATE of bug 17991
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-21 01:12 UTC by Hermann Schichl
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 20:36:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hermann Schichl 2001-02-21 01:12:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.23 i686)


When starting the XFree86 4.0.2 server on a ASUS L8400C Laptop with
  S3 Inc. 86C270-294 Savage/MX-/IX (rev 11)
the computer crashes completely. Screen shows X pattern background
with some distortions in the upper 5th of the screen, kbd, mouse, eth
interface
don't react anymore. Only possibility for recovery is power cycle.
Crashes sometimes at first X start. Crashes every time at second try (e.g.
using [xkg]dm after logout, or using startx twice,...)

Reproducible: Always
Steps to Reproduce:
1. start X using startx (or using xdm, init 5) - crashes already in some
cases
2. shut down X (logout or Ctrl-Alt-BS) - crashes in few cases
3. start X again using startx (if using xdm this is done automatically) -
crashes always at this step at the latest.
	

Actual Results:  computer refused to do anything except for reacting to
power cycle.

Expected Results:  X should have worked

Workaround: Switch back to XF86_SVGA from XFree86-SVGA-3.3.6-33
                   which works w/o problems.

Comment 1 Mike A. Harris 2001-02-21 04:17:01 UTC
Please attach the X server logs to the bug report, and your configuration
files for X.  I need the full details from the server logs to diagnose
the problem.

Comment 2 Glen Foster 2001-02-21 20:36:38 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 3 Mike A. Harris 2001-02-28 06:35:05 UTC
Never mind the logs, and stuff.  This is a duplicate, and a fix is in the
works. 

*** This bug has been marked as a duplicate of 17991 ***


Note You need to log in before you can comment on or make changes to this bug.