Bug 2853 - xterm doesn't handle SIGINT
Summary: xterm doesn't handle SIGINT
Status: CLOSED DUPLICATE of bug 2854
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-16 20:14 UTC by ak
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-16 20:38:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ak 1999-05-16 20:14:38 UTC
xterm cannot process SIGINT. When it gets a SIGINT this
happens (shown from strace):

select(7, [4 6], [], NULL, NULL)        = ? ERESTARTNOHAND
(To be restarted)
--- SIGINT (Interrupt) ---
fork()                                  = 9747
wait4(9747, NULL, 0, NULL)              = 9747
--- SIGCHLD (Child exited) ---
wait4(-1,

after that it hangs and can only be killed with
SIGTERM/SIGKILL. This is unique to the RH6 xterm,
Dickey's latest version or earlier versions didn't
have that problem.

It has been observed on a Alpha too.

-Andi

Comment 1 Jeff Johnson 1999-05-16 20:38:59 UTC
*** This bug has been marked as a duplicate of 2854 ***


Note You need to log in before you can comment on or make changes to this bug.