Bug 2854 - xterm doesn't handle SIGINT
xterm doesn't handle SIGINT
Status: CLOSED DUPLICATE of bug 2767
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
: 2853 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-16 16:14 EDT by ak
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-19 11:17:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ak 1999-05-16 16:14:40 EDT
xterm cannot process SIGINT. When it gets a SIGINT this
happens (shown from strace):

select(7, [4 6], [], NULL, NULL)        = ? ERESTARTNOHAND
(To be restarted)
--- SIGINT (Interrupt) ---
fork()                                  = 9747
wait4(9747, NULL, 0, NULL)              = 9747
--- SIGCHLD (Child exited) ---
wait4(-1,

after that it hangs and can only be killed with
SIGTERM/SIGKILL. This is unique to the RH6 xterm,
Dickey's latest version or earlier versions didn't
have that problem.

It has been observed on a Alpha too.

-Andi
Comment 1 Jeff Johnson 1999-05-16 16:38:59 EDT
*** Bug 2853 has been marked as a duplicate of this bug. ***


xterm cannot process SIGINT. When it gets a SIGINT this
happens (shown from strace):

select(7, [4 6], [], NULL, NULL)        = ? ERESTARTNOHAND
(To be restarted)
--- SIGINT (Interrupt) ---
fork()                                  = 9747
wait4(9747, NULL, 0, NULL)              = 9747
--- SIGCHLD (Child exited) ---
wait4(-1,

after that it hangs and can only be killed with
SIGTERM/SIGKILL. This is unique to the RH6 xterm,
Dickey's latest version or earlier versions didn't
have that problem.

It has been observed on a Alpha too.

-Andi
Comment 2 Jay Turner 1999-05-19 11:17:59 EDT
*** This bug has been marked as a duplicate of 2767 ***

Note You need to log in before you can comment on or make changes to this bug.