Bug 286381 - Window management broke after restoring session with Firefox (after update)
Window management broke after restoring session with Firefox (after update)
Status: CLOSED DUPLICATE of bug 243761
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
7
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-11 13:16 EDT by Jim Avera
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 13:31:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from rpm -q -a (23.83 KB, text/plain)
2007-09-11 13:16 EDT, Jim Avera
no flags Details

  None (edit)
Description Jim Avera 2007-09-11 13:16:47 EDT
All window-manager functions are broken after restoring any session
containing a firefox window -- window borders are missing and Alt-button1
etc. do nothing.   [window manager crashed trying to restore ff ???]

This occurs after updating a fresh fc7 install, so the problem seems
related to the update.   The update changed firefox and many gnome modules.

Verson: f7 + yum update

HOW TO REPRODUCE:
1. Install fc7 from DVD, selecting both Desktop and Development pkg groups
   # yum update ; reboot
   # useradd -m testuser   (create brand-new user home directory)
   # passwd testuser

2. Log in as testuser via gdm, selecting GNOME session.
   Start a couple of terminal windows using the menus.
   Set "automatically save session" in Preferences->Personal->Session
   log out & back in
   Observe terminals were restored and WM functions normally

3. Log in again and start firefox using the browser button.
   log out (no warning dialog appears saying firefox won't be restored).
   log in -- window borders are missing and firefox is not restored.
     Prefs->Personal->Session->Current Session does -not- list firefox.
     All subsequent logins by that user are similarly hosed.

NOTE: Prior to the update (after a fresh fc7 install from DVD),
logging out with firefox running and auto session save enabled
resulted in a popup saying firefox won't be restored because it doesn't
understand session management (same as in fc6 with ff 1.5).  Subsequent
logins worked normally and ff was not restored, as per the warning.
AFTER updating the system, the ff-wont-be-saved warning did
not appear when logging out, and subsequent logins were hosed.

Reproducible: Every time

This is an urgent issue to the extent that session saving is
required to work (because people -will- run firefox).
Comment 1 Jim Avera 2007-09-11 13:16:48 EDT
Created attachment 192721 [details]
Output from rpm -q -a
Comment 2 Jim Avera 2007-09-11 13:28:08 EDT
P.S. Enhanced Window Effects (or whatever it's called) was -not- enabled.
Comment 3 Ray Strode [halfline] 2007-09-11 13:31:34 EDT

*** This bug has been marked as a duplicate of 243761 ***

Note You need to log in before you can comment on or make changes to this bug.