Bug 28810 - Option I (for bz2 files..) dont work anymore..
Summary: Option I (for bz2 files..) dont work anymore..
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tar (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-22 10:10 UTC by Anvil
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-26 01:50:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anvil 2001-02-22 10:10:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [fr] (X11; U; Linux 2.4.0 i686)


I got this output..
[root@gruyere /usr/src]# tar Ixvf MesaDemos-3.4.tar.bz2
tar: This does not look like a tar archive
tar: Skipping to next header
tar: 412 garbage bytes ignored at end of archive
tar: Error exit delayed from previous errors
zsh: exit 2     tar Ixvf MesaDemos-3.4.tar.bz2

But when I bunzip the file there is no problem. I can even tar xvf it
after.

Reproducible: Always
Steps to Reproduce:
1. found a tar.bz2 file
2. tar Ixvf file.tar.bz2
3.
	

Actual Results:  See above.

Expected Results:  Tar should extract the archive from tar.bz2 file.

Comment 1 Anvil 2001-02-22 10:20:02 UTC
NOT A BUG... the option is now -j for bzipped files..

Comment 2 James Manning 2002-06-08 20:16:47 UTC
reopening since it's a doc bug in the man page, although lower priority since
it's fine in info and man is deprecated in favor of info, yadda yadda yadda

Comment 3 Jeff Johnson 2002-11-22 15:09:55 UTC
The -I option is still present, displays
useful usage message:

bash$ tar cIvf abc.tar.bz2 abc
tar: Warning: the -I option is not supported; perhaps you meant -j or -T?
Try `tar --help' for more information.



Note You need to log in before you can comment on or make changes to this bug.