This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 288371 - [RHEL5.1]: ia64 pygrub parses elilo.conf incorrectly/incompletely
[RHEL5.1]: ia64 pygrub parses elilo.conf incorrectly/incompletely
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lalancette
Virtualization Bugs
:
: 284731 (view as bug list)
Depends On: 252957
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-12 15:48 EDT by Chris Lalancette
Modified: 2009-12-14 16:09 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0305
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:20:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backport of upstream xen-unstable c/s 15690 for the elilo issue (1.78 KB, patch)
2007-12-20 16:28 EST, Chris Lalancette
no flags Details | Diff

  None (edit)
Description Chris Lalancette 2007-09-12 15:48:15 EDT
+++ This bug was initially created as a clone of Bug #252957 +++

The long and short of this bug is that the code we currently have in pygrub
fails to completely parse the elilo.conf.  Additionally, it contains a bug where
if there is no "append" line at all in an "image", it will cause pygrub to
stacktrace.  Both of these are fixed by the following upstream changeset:

http://lists.xensource.com/archives/html/xen-devel/2007-08/msg00052.html

Which should be easy to backport to RHEL-5.
Comment 1 Chris Lalancette 2007-09-19 09:19:01 EDT
*** Bug 284731 has been marked as a duplicate of this bug. ***
Comment 2 RHEL Product and Program Management 2007-10-15 23:40:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Chris Lalancette 2007-12-14 16:39:01 EST
To be more specific, here is the upstream changeset:

http://xenbits.xensource.com/xen-unstable.hg?rev/fd20c1333e3e

Chris Lalancette
Comment 4 Bill Burns 2007-12-17 15:46:02 EST
Setting devel ack for Chris L.
Comment 6 Chris Lalancette 2007-12-20 16:28:07 EST
Created attachment 290191 [details]
Backport of upstream xen-unstable c/s 15690 for the elilo issue
Comment 7 Daniel Berrange 2008-01-03 16:10:32 EST
Fix built for QA

$ brew latest-pkg dist-5E-qu-candidate xen
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
xen-3.0.3-43.el5                          dist-5E-qu-candidate  berrange

* Thu Jan  3 2008 Daniel P. Berrange <berrange@redhat.com> - 3.0.3-43.el5
- Fix handling of lilo.conf for ia64 (rhbz #288371)
Comment 10 errata-xmlrpc 2008-05-21 11:20:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0305.html

Note You need to log in before you can comment on or make changes to this bug.