Bug 2886 - NIS netgroup map not used for exporting filesystems
NIS netgroup map not used for exporting filesystems
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: knfsd (Show other bugs)
6.0
All Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
: 2950 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-17 15:34 EDT by Joshua Buysse
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-18 12:31:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Buysse 1999-05-17 15:34:46 EDT
The kernel nfsd is ignoring @netgroup entries in the
/etc/exports file.  Placing a host that is alone in a
netgroup, like this:
(netgroups)
thor_socsci (thor.socsci.umn.edu,,) (thor,,)

into exports like this
/files  @thor_socsci(rw)

does not work.
/files  thor.socsci.umn.edu(rw)

does work.



------- Additional Comments From   06/16/99 12:20 -------
Oddly enough, it is working on a machine that I just installed from a
'official' redhat box.  It does not work from a machine that I
installed from the downloaded version (downloaded before RH6 was
officially available).

I'll check the versions of the kernel and knfsd RPMs on the box that
does not work.
Comment 1 Jeff Johnson 1999-06-18 12:31:59 EDT
Replace the token "nss" with "compat" in the hosts line in
/etc/nsswitch.conf to get something like
	hosts	files nisplus compat dns

This should enable netgroup substitution (e.g. your @thor_socsci)
in a host lookup context.

Please reopen if this does not work.
Comment 2 Jeff Johnson 1999-06-18 12:35:59 EDT
*** Bug 2950 has been marked as a duplicate of this bug. ***

nice one.. now all my machines cannot export with uid
or gid maps since EXPORTFS doesn't seem to understand
what nis or static maps are.  also.. mountd's manpage is
gone, so is nfsd's

this package is grandly screwed


------- Additional Comments From jbj@redhat.com  06/18/99 12:34 -------
Replace the token "nis" with "compat" in /etc/nsswtch.conf to
enable netgroup substitution.

The package knfsd-1.4-1 contains man pages.

Note You need to log in before you can comment on or make changes to this bug.