Bug 288921 - Output defaults to esd instead of alsa ?
Output defaults to esd instead of alsa ?
Status: CLOSED DUPLICATE of bug 200688
Product: Fedora
Classification: Fedora
Component: timidity++ (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 03:43 EDT by Martin Tarenskeen
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-13 02:34:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Tarenskeen 2007-09-13 03:43:39 EDT
Description of problem:

When I run timidity without arguments it seems to default to Enlightened Sound
Demon, giiving an error message:
esd: No such file or directory
Couldn't open enlightened sound demon (`e')
I have to use -Os to enforce alsa output. Taking a look at the specfile in the
src.rpm I see it does try to configure timidity with alsa as default output.
(--with-default-output=alsa)  strange.

Version-Release number of selected component (if applicable):
timidity++-2.13.2-1.2.2

My workaround: I removed "esd" from the "--enable-audio=" list in my SPECfile.
Maybe someone can up with something better?

How reproducible:
Always, at least on my system.
Comment 1 Martin Tarenskeen 2007-09-18 02:35:20 EDT
I found a btter fix. I disabled the TiMidity-2.13.0-detect.patch the specfile.
Apparently it doesn't work properly anyway.
This would fix bug #200688 and 288921.
Comment 2 Hans de Goede 2007-10-13 02:34:42 EDT
Hi all,

Nigel is no longer the timidity maintainer, Jindrich Novy and I are now
maintaing timidity, closing this one as a dup of bug 200688.


*** This bug has been marked as a duplicate of 200688 ***

Note You need to log in before you can comment on or make changes to this bug.